summaryrefslogtreecommitdiffstats
path: root/system/slim/slim.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/slim/slim.SlackBuild')
-rw-r--r--system/slim/slim.SlackBuild31
1 files changed, 20 insertions, 11 deletions
diff --git a/system/slim/slim.SlackBuild b/system/slim/slim.SlackBuild
index 14a909e48e..7c434e6a99 100644
--- a/system/slim/slim.SlackBuild
+++ b/system/slim/slim.SlackBuild
@@ -2,6 +2,8 @@
# Slackware build script for SLiM
+# Ryan P.C. McQuen | Everett, WA | ryan.q@linux.com
+
# Copyright 2006 Martin Lefebvre <dadexter@gmail.com>
# Copyright 2007-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
# Copyright 2010,2013 Niels Horn, Rio de Janeiro, Brazil
@@ -24,10 +26,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# revision date: 2013/03/30
-
PRGNAM=slim
-VERSION=${VERSION:-1.3.5}
+VERSION=${VERSION:-1.3.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -68,16 +68,19 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Correct the path used for suspend:
patch -p0 < $CWD/slim.conf.patch
+# disable slimlock build
+patch -p0 < $CWD/CMakeLists.txt.patch
# Fix location of man-pages
sed "s/share\/man/man/" -i CMakeLists.txt
+sed -i "s/DESTINATION lib/DESTINATION lib${LIBDIRSUFFIX}/" CMakeLists.txt
mkdir -p build
cd build
@@ -85,6 +88,7 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_CONSOLEKIT=yes \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
@@ -103,15 +107,20 @@ cat $CWD/slim.logrotate > $PKG/etc/logrotate.d/slim.new
# Kill the incorrectly-placed (and useless anyway) systemd stuff
rm -rf $PKG/usr/usr
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+# Kill systemd stuff
+rm -rf $PKG/lib
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+# Remove slimlock as we don't build it
+rm $PKG/usr/man/man1/slimlock.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- ChangeLog COPYING INSTALL README THEMES TODO xinitrc.sample \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog COPYING INSTALL README THEMES TODO xinitrc.sample $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE