summaryrefslogtreecommitdiffstats
path: root/system/slpkg
diff options
context:
space:
mode:
Diffstat (limited to 'system/slpkg')
-rw-r--r--system/slpkg/README41
-rw-r--r--system/slpkg/doinst.sh11
-rw-r--r--system/slpkg/slack-desc10
-rw-r--r--system/slpkg/slpkg.SlackBuild47
-rw-r--r--system/slpkg/slpkg.info10
5 files changed, 48 insertions, 71 deletions
diff --git a/system/slpkg/README b/system/slpkg/README
index 5828dd8d0e..94145cfd3e 100644
--- a/system/slpkg/README
+++ b/system/slpkg/README
@@ -1,36 +1,5 @@
-Slpkg is a powerful software package manager that installs,
-updates, and removes packages on Slackware based systems.
-It automatically computes dependencies and figures out what
-things should occur to install packages. Slpkg makes it easier
-to maintain groups of machines without having to manually update.
-Slpkg works in accordance with the standards of the organization
-slackbuilds.org to builds packages. Also uses the Slackware Linux
-instructions for installation, upgrading or removing packages.
-
-What makes slpkg to distinguish it from the other tools;
-The user-friendliness it's a primary target as well as easy to
-understand and use, also use colours (by default) to highlight
-packages and display warning messages, and many of the others
-available options it's ready to use.
-
-Features
-
-* Dependencies resolutions
-* Dependencies visualizations
-* Multiple options
-* Multiple repositories
-* Easy configuration
-* Fully configurable
-* Adaptability
-* Powerful options
-* Source builder
-* Faster process
-* Better Security
-
-Optional dependencies:
-
-* python3-pythondialog (for dialog box interface)
-* pygraphviz (for drawing dependencies diagram)
-* graph-easy (for drawing ascii dependencies diagram)
-* aria2 (alternative downloader)
-* httpie (alternative downloader)
+Slpkg is a software package manager that installs, updates and
+removes packages on Slackware-based systems. It automatically
+calculates dependencies and figures out what things need to
+happen to install packages. Slpkg makes it easier to manage
+groups of machines without the need for manual updates.
diff --git a/system/slpkg/doinst.sh b/system/slpkg/doinst.sh
index 67244ee97e..ad7af35073 100644
--- a/system/slpkg/doinst.sh
+++ b/system/slpkg/doinst.sh
@@ -8,12 +8,7 @@ config() {
fi
}
-CONFIGS="slpkg.conf repositories.conf blacklist slackware-mirrors \
- default-repositories custom-repositories rlworkman.deps pkg_security"
-for file in $CONFIGS; do
- config etc/slpkg/${file}.new
+FILES="slpkg repositories blacklist"
+for file in $FILES; do
+ config etc/slpkg/$file.toml.new
done
-
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/system/slpkg/slack-desc b/system/slpkg/slack-desc
index 9eebd74623..e9abbc7cd9 100644
--- a/system/slpkg/slack-desc
+++ b/system/slpkg/slack-desc
@@ -8,11 +8,11 @@
|-----handy-ruler------------------------------------------------------|
slpkg: slpkg (Slackware Packaging Tool)
slpkg:
-slpkg: Slpkg is a powerful software package manager that installs, updates
-slpkg: and removes packages on Slackware based systems. It automatically
-slpkg: computes dependencies and figures out what things should occur
-slpkg: to install packages. Slpkg makes it easier to maintain groups of
-slpkg: of machines without having to manually update.
+slpkg: Slpkg is a software package manager that installs, updates and
+slpkg: removes packages on Slackware-based systems. It automatically
+slpkg: calculates dependencies and figures out what things need to
+slpkg: happen to install packages. Slpkg makes it easier to manage
+slpkg: groups of machines without the need for manual updates.
slpkg:
slpkg: Homepage: https://dslackw.gitlab.io/slpkg
slpkg:
diff --git a/system/slpkg/slpkg.SlackBuild b/system/slpkg/slpkg.SlackBuild
index 05fdb9c3a6..d2ff762ba2 100644
--- a/system/slpkg/slpkg.SlackBuild
+++ b/system/slpkg/slpkg.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for slpkg
-# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=slpkg
-VERSION=${VERSION:-3.7.2}
+VERSION=${VERSION:-5.0.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,31 +79,34 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# avoid install configuration files and man page over setup.py
-sed -i 's/if "install"/if ""/' setup.py
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
-python3 setup.py install --root=$PKG
+# Move executables to the /usr/sbin folder.
+mkdir -p $PKG/usr/sbin
+mv $PKG/usr/bin/slpkg $PKG/usr/sbin/slpkg
+mv $PKG/usr/bin/slpkg_new-configs $PKG/usr/sbin/slpkg_new-configs
+rm -rf $PKG/usr/bin
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/etc/slpkg
-# install configuration files
-CONFIGS="slpkg.conf repositories.conf blacklist slackware-mirrors \
- default-repositories custom-repositories rlworkman.deps pkg_security"
-for file in $CONFIGS; do
- install -D -m0644 conf/$file $PKG/etc/slpkg/${file}.new
+FILES="slpkg repositories blacklist"
+for file in $FILES; do
+ install -D -m0644 configs/$file.toml $PKG/etc/slpkg/$file.toml.new
done
-# keep original configuration file for reset
-cp -p conf/slpkg.conf $PKG/etc/slpkg/slpkg.conf.orig
+mkdir -p $PKG/usr/man/man1 & mkdir -p $PKG/usr/man/fr/man1
+cp man/slpkg.1 $PKG/usr/man/man1
+cp man/slpkg-fr.1 $PKG/usr/man/fr/man1/slpkg.1
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md ChangeLog.txt LICENSE TESTING ISSUES KNOWN_ISSUES REPOSITORIES.md \
- INSTALL.md requirements.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md ChangeLog.txt LICENSE requirements.txt repositories.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -101,4 +114,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/slpkg/slpkg.info b/system/slpkg/slpkg.info
index 802acc6d5b..1d35a96f20 100644
--- a/system/slpkg/slpkg.info
+++ b/system/slpkg/slpkg.info
@@ -1,10 +1,10 @@
PRGNAM="slpkg"
-VERSION="3.7.2"
+VERSION="5.0.8"
HOMEPAGE="https://dslackw.gitlab.io/slpkg"
-DOWNLOAD="https://gitlab.com/dslackw/slpkg/-/archive/3.7.2/slpkg-3.7.2.tar.gz"
-MD5SUM="6740e8213bbaa8f8d674144f61954366"
+DOWNLOAD="https://gitlab.com/dslackw/slpkg/-/archive/5.0.8/slpkg-5.0.8.tar.gz"
+MD5SUM="4030e14f0a955c641636f630ba4e784c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3 python-requests"
+REQUIRES="python3-build python3-pythondialog"
MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+EMAIL="dslackw@gmail.com"