summaryrefslogtreecommitdiffstats
path: root/system/terminator
diff options
context:
space:
mode:
Diffstat (limited to 'system/terminator')
-rw-r--r--system/terminator/README9
-rw-r--r--system/terminator/terminator.SlackBuild25
-rw-r--r--system/terminator/terminator.info10
3 files changed, 27 insertions, 17 deletions
diff --git a/system/terminator/README b/system/terminator/README
index b3c2ba1f4f..59d346e0c1 100644
--- a/system/terminator/README
+++ b/system/terminator/README
@@ -1,6 +1,5 @@
The goal of this project is to produce a useful tool for arranging
-terminals. It is inspired by programs such as gnome-multi-term,
-quadkonsole, etc. in that the main focus is arranging terminals in grids
-(tabs is the most common default method, which Terminator also supports).
-
-Optionally requires python-keybinder
+terminals. It is inspired by programs such as gnome-multi-term,
+quadkonsole, etc. in that the main focus is arranging terminals in
+grids (tabs is the most common default method, which Terminator also
+supports).
diff --git a/system/terminator/terminator.SlackBuild b/system/terminator/terminator.SlackBuild
index 54a7a4ce2f..e8f7c5a953 100644
--- a/system/terminator/terminator.SlackBuild
+++ b/system/terminator/terminator.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for terminator
@@ -30,11 +30,15 @@
# 20130530 - Updated for version 0.97
# 20160625 - Updated for version 0.98 (thanks to Andrzej Telszewski)
# 20161126 - Updated for version 1.0
+# 20230507 - Updated for version 2.1.3
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=terminator
-VERSION=${VERSION:-1.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-2.1.3}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -44,12 +48,19 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="INSTALL COPYING RELEASING README ChangeLog"
+DOCS="INSTALL.md AUTHORS COPYING RELEASE.md README.md CHANGELOG.md CHANGELOG.legacy.txt TRANSLATION.md"
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
@@ -87,7 +98,7 @@ sed -i "s|'share', 'doc', 'terminator'|'doc', '$PRGNAM-$VERSION'|g" terminatorli
sed -i "s|share/man|man|g" setup.py
CFLAGS=$SLKCFLAGS \
-./setup.py --no-user-cfg --without-icon-cache install --prefix=/usr --root=$PKG
+python3 setup.py --no-user-cfg install --prefix=/usr --root=$PKG
rm -f $PKG/usr/doc/$PRGNAM-$VERSION/apidoc/.buildinfo
rm -f $PKG/usr/doc/$PRGNAM-$VERSION/html/.buildinfo
@@ -109,4 +120,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/terminator/terminator.info b/system/terminator/terminator.info
index 217966f2ae..3e84c51471 100644
--- a/system/terminator/terminator.info
+++ b/system/terminator/terminator.info
@@ -1,10 +1,10 @@
PRGNAM="terminator"
-VERSION="1.0"
-HOMEPAGE="https://launchpad.net/terminator/"
-DOWNLOAD="https://launchpad.net/terminator/trunk/1.0/+download/terminator-1.0.tar.gz"
-MD5SUM="26b2c80a30bead957b83cef3a2b9101f"
+VERSION="2.1.3"
+HOMEPAGE="https://github.com/gnome-terminator/terminator"
+DOWNLOAD="https://github.com/gnome-terminator/terminator/releases/download/v2.1.3/terminator-2.1.3.tar.gz"
+MD5SUM="c15ed0329bd324fb3f0c59a88650780f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="psutil"
+REQUIRES="python3-pytest-runner python3-psutil configobj"
MAINTAINER="Alan Alberghini"
EMAIL="414N@slacky.it"