summaryrefslogtreecommitdiffstats
path: root/system/tmuxp
diff options
context:
space:
mode:
Diffstat (limited to 'system/tmuxp')
-rw-r--r--system/tmuxp/tmuxp.SlackBuild50
-rw-r--r--system/tmuxp/tmuxp.info12
2 files changed, 33 insertions, 29 deletions
diff --git a/system/tmuxp/tmuxp.SlackBuild b/system/tmuxp/tmuxp.SlackBuild
index e1e4f02d0e..022f11b853 100644
--- a/system/tmuxp/tmuxp.SlackBuild
+++ b/system/tmuxp/tmuxp.SlackBuild
@@ -1,8 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for tmuxp
-# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +23,19 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220512 46and2: Updated version, fix README, New maintainer.
+# 20220919 46and2: Updated version, change build process.
+# 20221007 46and2: Updated version, drop kaptan as dep.
+# 20221007 46and2: Rebuilt for python3-libtmux
+# 20221210 46and2: Updated version, drop click dep.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=tmuxp
-VERSION=${VERSION:-1.5.4}
+VERSION=${VERSION:-1.45.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,25 +45,15 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -65,22 +65,26 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES LICENSE PKG-INFO README.rst doc/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES LICENSE PKG-INFO README.md docs/*.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# examples
+install -vDm 644 examples/*.{json,yaml} -t "$PKG/usr/doc/$PRGNAM-$VERSION/examples/"
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/tmuxp/tmuxp.info b/system/tmuxp/tmuxp.info
index c33932a7a9..c134edec3d 100644
--- a/system/tmuxp/tmuxp.info
+++ b/system/tmuxp/tmuxp.info
@@ -1,10 +1,10 @@
PRGNAM="tmuxp"
-VERSION="1.5.4"
+VERSION="1.45.0"
HOMEPAGE="https://github.com/tony/tmuxp/"
-DOWNLOAD="https://files.pythonhosted.org/packages/0f/ce/c06eb1dec939d75c60b837528e8205590d0306ced5fa9046f4029fb6058b/tmuxp-1.5.4.tar.gz"
-MD5SUM="2bdbaef671e97ff5658165f67e627df5"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/t/tmuxp/tmuxp-1.45.0.tar.gz"
+MD5SUM="2b137a14e27b20c0b6112e467b333b99"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="kaptan click colorama python-libtmux"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+REQUIRES="colorama python3-libtmux"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"