summaryrefslogtreecommitdiffstats
path: root/academic/suitesparseconfig/autotoolize.diff
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2014-01-24 20:18:34 -0600
committer Robby Workman <rworkman@slackbuilds.org>2014-01-31 00:53:18 -0600
commitb312365c1c38d4c1c7bfe07de978b587d0e1edae (patch)
tree16aa4aff1ab4a5f633bbe95026eab35b9860c87e /academic/suitesparseconfig/autotoolize.diff
parent6dfc3f0199da616d39e3f55ae7a7a800de46cc71 (diff)
downloadslackbuilds-b312365c1c38d4c1c7bfe07de978b587d0e1edae.tar.gz
slackbuilds-b312365c1c38d4c1c7bfe07de978b587d0e1edae.tar.xz
academic/suitesparseconfig: Renamed and moved from libraries.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'academic/suitesparseconfig/autotoolize.diff')
-rw-r--r--academic/suitesparseconfig/autotoolize.diff85
1 files changed, 85 insertions, 0 deletions
diff --git a/academic/suitesparseconfig/autotoolize.diff b/academic/suitesparseconfig/autotoolize.diff
new file mode 100644
index 0000000000..495a940f10
--- /dev/null
+++ b/academic/suitesparseconfig/autotoolize.diff
@@ -0,0 +1,85 @@
+diff --git a/Makefile.am b/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Makefile.am
+@@ -0,0 +1,15 @@
++SUBDIRS = xerbla
++
++EXTRA_DIST = README.txt
++
++# Octave doesn't find SuiteSparse_config.h if it's placed in a non-default search path.
++# Don't put it in a subdirectory for now. Update suitesparseconfig.pc.in if this changes.
++#pkginclude_HEADERS = SuiteSparse_config.h
++include_HEADERS = SuiteSparse_config.h
++
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = suitesparseconfig.pc
++
++lib_LTLIBRARIES = libsuitesparseconfig.la
++libsuitesparseconfig_la_SOURCES = SuiteSparse_config.c
++libsuitesparseconfig_la_LDFLAGS = -no-undefined -version-number 4:2:1
+diff --git a/configure.ac b/configure.ac
+new file mode 100644
+--- /dev/null
++++ b/configure.ac
+@@ -0,0 +1,32 @@
++# -*- Autoconf -*-
++# Process this file with autoconf to produce a configure script.
++
++AC_PREREQ([2.69])
++AC_INIT([SuiteSparse_config],[4.2.1],[DrTimothyAldenDavis@gmail.com],[suitesparseconfig],[http://www.suitesparse.com/])
++AC_CONFIG_SRCDIR([SuiteSparse_config.c])
++AC_CONFIG_HEADERS([config.h])
++AM_INIT_AUTOMAKE([foreign])
++LT_INIT
++
++# Checks for programs.
++AC_PROG_INSTALL
++AC_PROG_CC
++AC_PROG_F77
++
++# Checks for libraries.
++
++# Checks for header files.
++AC_CHECK_HEADERS([limits.h stdlib.h])
++
++# Checks for typedefs, structures, and compiler characteristics.
++AC_TYPE_SIZE_T
++
++# Checks for library functions.
++AC_FUNC_MALLOC
++AC_CHECK_FUNCS([clock_gettime])
++
++AC_CONFIG_FILES([
++ suitesparseconfig.pc
++ Makefile
++ xerbla/Makefile])
++AC_OUTPUT
+diff --git a/suitesparseconfig.pc.in b/suitesparseconfig.pc.in
+new file mode 100644
+--- /dev/null
++++ b/suitesparseconfig.pc.in
+@@ -0,0 +1,11 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: @PACKAGE_NAME@
++Description: SuiteSparse common library
++Version: @PACKAGE_VERSION@
++URL: @PACKAGE_URL@
++Libs: -L${libdir} -lsuitesparseconfig
++Cflags: -I${includedir}
+diff --git a/xerbla/Makefile.am b/xerbla/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/xerbla/Makefile.am
+@@ -0,0 +1,7 @@
++noinst_HEADERS = xerbla.h
++noinst_LTLIBRARIES = libxerbla.la libcerbla.la
++
++libxerbla_la_SOURCES = xerbla.f
++libxerbla_la_FFLAGS = $(AM_FFLAGS)
++libcerbla_la_SOURCES = xerbla.c
++libcerbla_la_CFLAGS = $(AM_CFLAGS)