summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author grissiom <chaos.proton@gmail.com>2010-05-12 23:27:42 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:27:42 +0200
commit354aea4aa1ca248c1eabc5e747c793d938918cf1 (patch)
treef99d606bae7319e016fe5ed6d4d59cead5766892 /academic
parent53a10a02a59196d1bc3e034374ab9548dbe67c9b (diff)
downloadslackbuilds-354aea4aa1ca248c1eabc5e747c793d938918cf1.tar.gz
slackbuilds-354aea4aa1ca248c1eabc5e747c793d938918cf1.tar.xz
academic/sympy: Added to 12.2 repository
Diffstat (limited to 'academic')
-rw-r--r--academic/sympy/README6
-rw-r--r--academic/sympy/slack-desc19
-rw-r--r--academic/sympy/sympy.SlackBuild52
-rw-r--r--academic/sympy/sympy.info8
4 files changed, 85 insertions, 0 deletions
diff --git a/academic/sympy/README b/academic/sympy/README
new file mode 100644
index 0000000000..c5f09e0c67
--- /dev/null
+++ b/academic/sympy/README
@@ -0,0 +1,6 @@
+SymPy is a Python library for symbolic mathematics. It aims to become a
+full-featured computer algebra system (CAS) while keeping the code as simple as
+possible in order to be comprehensible and easily extensible. SymPy is written
+entirely in Python and does not require any external libraries.
+
+If you install iPython on your machine, sympy could take advantage of it.
diff --git a/academic/sympy/slack-desc b/academic/sympy/slack-desc
new file mode 100644
index 0000000000..58fe4ba7b2
--- /dev/null
+++ b/academic/sympy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+sympy: SymPy (Python library for symbolic mathematics)
+sympy:
+sympy: SymPy aims to become a full-featured computer algebra system (CAS)
+sympy: while keeping the code as simple as possible in order to be
+sympy: comprehensible and easily extensible. SymPy is written entirely in
+sympy: Python and does not require any external libraries.
+sympy:
+sympy:
+sympy: Homepage: http://code.google.com/p/sympy/
+sympy:
+sympy:
diff --git a/academic/sympy/sympy.SlackBuild b/academic/sympy/sympy.SlackBuild
new file mode 100644
index 0000000000..2df87372fb
--- /dev/null
+++ b/academic/sympy/sympy.SlackBuild
@@ -0,0 +1,52 @@
+#!/bin/sh
+
+# Slackware build script for sympy
+
+# Written by Grissiom <chaos.proton@gmail.com>
+
+PRGNAM=sympy
+VERSION=${VERSION:-0.6.4}
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mv $PKG/usr/share/man $PKG/usr/man
+rmdir $PKG/usr/share
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS LICENSE README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/academic/sympy/sympy.info b/academic/sympy/sympy.info
new file mode 100644
index 0000000000..4883b2ade3
--- /dev/null
+++ b/academic/sympy/sympy.info
@@ -0,0 +1,8 @@
+PRGNAM="sympy"
+VERSION="0.6.4"
+HOMEPAGE="http://code.google.com/p/sympy/"
+DOWNLOAD="http://sympy.googlecode.com/files/sympy-0.6.4.tar.gz"
+MD5SUM="5b1c4f76d5b7e1477c852a0ec2201092"
+MAINTAINER="grissiom"
+EMAIL="chaos.proton@gmail.com"
+APPROVED="dsomero"