summaryrefslogtreecommitdiffstats
path: root/audio/abcde/abcde.SlackBuild
diff options
context:
space:
mode:
author Andreas Voegele <andreas@andreasvoegele.com>2016-01-12 00:16:09 +0700
committer Robby Workman <rworkman@slackbuilds.org>2016-01-12 21:58:11 -0600
commit32b31541ea674c77a1c8e6481d44d10ea034ba16 (patch)
tree8d36ba1da8c18caf75e0f9b8f17ed130ee430141 /audio/abcde/abcde.SlackBuild
parentea7d87c52110cfa2d5952d2f176166dab7fc4645 (diff)
downloadslackbuilds-32b31541ea674c77a1c8e6481d44d10ea034ba16.tar.gz
slackbuilds-32b31541ea674c77a1c8e6481d44d10ea034ba16.tar.xz
audio/abcde: Updated for version 2.7.1 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio/abcde/abcde.SlackBuild')
-rw-r--r--audio/abcde/abcde.SlackBuild40
1 files changed, 14 insertions, 26 deletions
diff --git a/audio/abcde/abcde.SlackBuild b/audio/abcde/abcde.SlackBuild
index f232bfc94f..97addbabaa 100644
--- a/audio/abcde/abcde.SlackBuild
+++ b/audio/abcde/abcde.SlackBuild
@@ -25,9 +25,10 @@
# Modified by the SlackBuilds.org project
# Modified by Andrew Strong
# Modified by Glenn Becker
+# Modified by Andreas Voegele
PRGNAM=abcde
-VERSION=${VERSION:-2.6}
+VERSION=${VERSION:-2.7.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -48,8 +49,8 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-rm -rf $TMP/$PRGNAM-$VERSION
cd $TMP
+rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
@@ -57,39 +58,26 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix mandir and remove setting of ownership during install
-# The mandir can easily be changed by passing a 'mandir' variable to the
-# 'make install' process, but the setting of ownership isn't so easy to
-# work around without a patch. This isn't an issue if the SlackBuild
-# script is run as root, but I'm guessing that I'm not the only person who
-# likes to test a script as normal user before running it as root, and the
-# ownership setting in the Makefile will break installs as a normal user.
-# --rworkman
-patch -p1 < $CWD/Makefile.diff
+patch -p1 < $CWD/id3-genre.diff
-# fix to mailx call: the command was using the -a option which, in Slackware's
-# mailx, means something different than what was intended here (intent here is
-# to set content type to UTF-8. In Slackware the -a is unnecessary. Thanks to
-# Andreas Vogele for this patch. --gbecker
-patch -p1 < $CWD/cddb-tool.diff
-
-# Removed aac/speex patch as this was fixed upstream - G Becker 10.7.12
-
-make install DESTDIR=$PKG
+make install DESTDIR=$PKG \
+ prefix=/usr \
+ sysconfdir=/etc \
+ docdir=/usr/doc/$PRGNAM-$VERSION \
+ mandir=/usr/man
# Let's not overwrite the config file if it already exists
mv $PKG/etc/$PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING FAQ README TODO changelog examples $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
-
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING FAQ README changelog examples $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh