summaryrefslogtreecommitdiffstats
path: root/audio/bristol/bristol.SlackBuild
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2011-08-26 19:03:23 -0300
committer Niels Horn <niels.horn@slackbuilds.org>2011-08-26 19:03:23 -0300
commitedcad06d1d5fa7354648d2cdf4bb1a17e0e83a09 (patch)
tree2984067feb5435d8a3f62a9a77211db4754fa813 /audio/bristol/bristol.SlackBuild
parent7ab8ff8f34347e0a1075b00900a56110e033b988 (diff)
downloadslackbuilds-edcad06d1d5fa7354648d2cdf4bb1a17e0e83a09.tar.gz
slackbuilds-edcad06d1d5fa7354648d2cdf4bb1a17e0e83a09.tar.xz
audio/bristol: Updated for version 0.60.8 (+new maintainer)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'audio/bristol/bristol.SlackBuild')
-rw-r--r--audio/bristol/bristol.SlackBuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/audio/bristol/bristol.SlackBuild b/audio/bristol/bristol.SlackBuild
index 80f3db3e7b..1df9947eeb 100644
--- a/audio/bristol/bristol.SlackBuild
+++ b/audio/bristol/bristol.SlackBuild
@@ -2,10 +2,11 @@
# Slackware build script for bristol
-# Written by Zbigniew Baniewski, zb@ispid.com.pl
+# Written by Zbigniew Baniewski, zb@ispid.com.pl (email no longer valid?)
+# Modified by B. Watson, yalhcru@gmail.com
PRGNAM=bristol
-VERSION=0.60.7
+VERSION=0.60.8
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -51,6 +52,12 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Hard-coded /usr/lib and /usr/X11R6/lib sucks.
+sed -i "s,/usr/lib,/usr/lib$LIBDIRSUFFIX,g" \
+ configure Makefile.* brighton/Makefile.* libbrightonX11/Makefile.*
+sed -i "s,/usr/X11R6/lib,/usr/X11R6/lib$LIBDIRSUFFIX,g" \
+ configure Makefile.* brighton/Makefile.* libbrightonX11/Makefile.*
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -59,19 +66,16 @@ CXXFLAGS="$SLKCFLAGS" \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
+ --disable-static \
+ --enable-shared \
--build=$ARCH-slackware-linux
make
-make install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+make install-strip DESTDIR=$PKG
+# "install -m0644" rather than "cp -a" so the docs aren't executable!
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING COPYING.GPL NEWS README ChangeLog \
+install -m0644 AUTHORS COPYING COPYING.GPL NEWS README ChangeLog \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild