summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2021-04-19 19:37:40 +0200
committer Matteo Bernardini <ponce@slackbuilds.org>2021-04-19 19:37:40 +0200
commit6ddaee0bdd3f9d44e90f5eea603b0d53bb549cbb (patch)
tree89bc986f51f1366134c1e935692e79867e51fce9 /audio
parentb0738bc1b45aa0cc55a22197381a256add6e08c3 (diff)
downloadslackbuilds-6ddaee0bdd3f9d44e90f5eea603b0d53bb549cbb.tar.gz
slackbuilds-6ddaee0bdd3f9d44e90f5eea603b0d53bb549cbb.tar.xz
audio/audacious-cue: Removed (added to Slackware).
...as part of audacious-plugins Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/audacious-cue/README4
-rw-r--r--audio/audacious-cue/audacious-cue.SlackBuild108
-rw-r--r--audio/audacious-cue/audacious-cue.info10
-rw-r--r--audio/audacious-cue/patches/enable_only_cue_plugin.diff8
-rw-r--r--audio/audacious-cue/slack-desc19
5 files changed, 0 insertions, 149 deletions
diff --git a/audio/audacious-cue/README b/audio/audacious-cue/README
deleted file mode 100644
index 3cfdd13876..0000000000
--- a/audio/audacious-cue/README
+++ /dev/null
@@ -1,4 +0,0 @@
-audacious-cue (Cue Sheet Plugin used by the Audacious media player)
-
-This plugin adds Cue Sheet support to the Audacious media player that
-comes with Slackware stock packages
diff --git a/audio/audacious-cue/audacious-cue.SlackBuild b/audio/audacious-cue/audacious-cue.SlackBuild
deleted file mode 100644
index 8d018fdadb..0000000000
--- a/audio/audacious-cue/audacious-cue.SlackBuild
+++ /dev/null
@@ -1,108 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for audacious-cue
-
-# Copyright 2012, 2015, 2016 Mario Preksavec, Zagreb, Croatia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=audacious-cue
-VERSION=${VERSION:-3.8.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=audacious-plugins
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- ARCHOPTS="--disable-sse2"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- ARCHOPTS="--disable-sse2"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- ARCHOPTS=""
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- ARCHOPTS=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Patch Makefile to build only cue plugin
-patch -p1 <$CWD/patches/enable_only_cue_plugin.diff || exit 1
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --enable-cue \
- --with-ffmpeg=none \
- --program-prefix= \
- --program-suffix= \
- --disable-aac \
- ${ARCHOPTS} \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING INSTALL $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/audacious-cue/audacious-cue.info b/audio/audacious-cue/audacious-cue.info
deleted file mode 100644
index 31b7a1a12c..0000000000
--- a/audio/audacious-cue/audacious-cue.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="audacious-cue"
-VERSION="3.8.2"
-HOMEPAGE="https://audacious-media-player.org/"
-DOWNLOAD="https://distfiles.audacious-media-player.org/audacious-plugins-3.8.2.tar.bz2"
-MD5SUM="20710cd19fa08c4bffb6cb33002872df"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="libcue"
-MAINTAINER="Mario Preksavec"
-EMAIL="mario at slackware dot hr"
diff --git a/audio/audacious-cue/patches/enable_only_cue_plugin.diff b/audio/audacious-cue/patches/enable_only_cue_plugin.diff
deleted file mode 100644
index 1752d61f43..0000000000
--- a/audio/audacious-cue/patches/enable_only_cue_plugin.diff
+++ /dev/null
@@ -1,8 +0,0 @@
---- audacious-plugins-3.2.4/Makefile.ORIG 2012-06-30 02:05:33.000000000 +0200
-+++ audacious-plugins-3.2.4/Makefile 2012-07-23 21:32:11.750875868 +0200
-@@ -1,4 +1,4 @@
--SUBDIRS = src po
-+SUBDIRS = src/cue
-
- DISTCLEAN = buildsys.mk config.h config.log config.status extra.mk
-
diff --git a/audio/audacious-cue/slack-desc b/audio/audacious-cue/slack-desc
deleted file mode 100644
index 6963a70363..0000000000
--- a/audio/audacious-cue/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-audacious-cue: audacious-cue (Cue Sheet Plugin used by the Audacious media player)
-audacious-cue:
-audacious-cue: This plugin adds Cue Sheet support to the Audacious media player that
-audacious-cue: comes with Slackware stock packages
-audacious-cue:
-audacious-cue: Homepage: https://audacious-media-player.org/
-audacious-cue:
-audacious-cue:
-audacious-cue:
-audacious-cue:
-audacious-cue: