summaryrefslogtreecommitdiffstats
path: root/desktop/awesome-extra/awesome-extra.SlackBuild
diff options
context:
space:
mode:
author Edinaldo P. Silva <edps.mundognu@gmail.com>2017-09-08 22:43:59 +0100
committer David Spencer <idlemoor@slackbuilds.org>2017-09-08 22:43:59 +0100
commit7626d60eb3de3784a9bcab2ae7705cebaf4fee36 (patch)
tree0a63608f6f9ca044958aa2d86fef1ea791f632dd /desktop/awesome-extra/awesome-extra.SlackBuild
parent480487aed2fd40514de2a2ba9b5df05b7e199265 (diff)
downloadslackbuilds-7626d60eb3de3784a9bcab2ae7705cebaf4fee36.tar.gz
slackbuilds-7626d60eb3de3784a9bcab2ae7705cebaf4fee36.tar.xz
desktop/awesome-extra: Updated for version 2017090101.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'desktop/awesome-extra/awesome-extra.SlackBuild')
-rw-r--r--desktop/awesome-extra/awesome-extra.SlackBuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/desktop/awesome-extra/awesome-extra.SlackBuild b/desktop/awesome-extra/awesome-extra.SlackBuild
index 05b240c98b..8e2be59657 100644
--- a/desktop/awesome-extra/awesome-extra.SlackBuild
+++ b/desktop/awesome-extra/awesome-extra.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=awesome-extra
-VERSION=${VERSION:-2016121101}
+VERSION=${VERSION:-2017090101}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -34,16 +34,13 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-SRCVER="2016121101+nmu1"
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}_${SRCVER}.tar.xz
-mv ${PRGNAM}-${SRCVER} $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_${VERSION}.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -58,11 +55,11 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
EXTRAS="flaw obvious revelation shifty vicious bashets/bashets.lua wicked/wicked.lua"
mkdir -p $PKG/usr/share/awesome/lib
-cp -a $EXTRAS $PKG/usr/share/awesome/lib/
+cp -r $EXTRAS $PKG/usr/share/awesome/lib/
mkdir -p $PKG/usr/man/man7
gzip -dc wicked/wicked.7.gz > $PKG/usr/man/man7/wicked.7
-cp -a flaw/flaw.7 $PKG/usr/man/man7/flaw.7
+cp flaw/flaw.7 $PKG/usr/man/man7/flaw.7
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
@@ -70,10 +67,10 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
DOCS="debian/awesome-extra.examples debian/changelog debian/copyright"
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cp $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
mv $PKG/usr/share/awesome/lib/shifty/README.md $PKG/usr/doc/$PRGNAM-$VERSION/README-shifty
-mv $PKG/usr/share/awesome/lib/vicious/README $PKG/usr/doc/$PRGNAM-$VERSION/README-vicious
-mv $PKG/usr/share/awesome/lib/vicious/contrib/README $PKG/usr/doc/$PRGNAM-$VERSION/README-vicious-contrib
+mv $PKG/usr/share/awesome/lib/vicious/README.md $PKG/usr/doc/$PRGNAM-$VERSION/README-vicious
+mv $PKG/usr/share/awesome/lib/vicious/contrib/README.md $PKG/usr/doc/$PRGNAM-$VERSION/README-vicious-contrib
mv $PKG/usr/share/awesome/lib/flaw/README $PKG/usr/doc/$PRGNAM-$VERSION/README-flaw
mv $PKG/usr/share/awesome/lib/obvious/README $PKG/usr/doc/$PRGNAM-$VERSION/README-obvious
mv $PKG/usr/share/awesome/lib/revelation/README.md $PKG/usr/doc/$PRGNAM-$VERSION/README-revelation