summaryrefslogtreecommitdiffstats
path: root/desktop/buku
diff options
context:
space:
mode:
author Anj Duvnjak <alvind11@hotmail.com>2020-02-08 01:57:05 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-02-08 01:57:05 +0700
commit4eea64847185951a76937c4e81037a3f8ee4c808 (patch)
tree195892dc263b99e24211672c794358516ca387e8 /desktop/buku
parent052ee1f23a65e328835c3c3a5f4fc29c45af0652 (diff)
downloadslackbuilds-4eea64847185951a76937c4e81037a3f8ee4c808.tar.gz
slackbuilds-4eea64847185951a76937c4e81037a3f8ee4c808.tar.xz
desktop/buku: Added (Cmdline bookmark manager).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop/buku')
-rw-r--r--desktop/buku/README9
-rw-r--r--desktop/buku/buku.SlackBuild95
-rw-r--r--desktop/buku/buku.info10
-rw-r--r--desktop/buku/slack-desc19
4 files changed, 133 insertions, 0 deletions
diff --git a/desktop/buku/README b/desktop/buku/README
new file mode 100644
index 0000000000..cfac0e6693
--- /dev/null
+++ b/desktop/buku/README
@@ -0,0 +1,9 @@
+buku (Cmdline bookmark manager with editor and browser integration)
+
+buku is a powerful bookmark manager written in Python3 and SQLite3.
+buku fetches the title of a bookmarked url and stores it along with
+any user-provided comments and tags.
+
+All buku dependencies must be built with Python 3.
+
+Optional dependency: xsel
diff --git a/desktop/buku/buku.SlackBuild b/desktop/buku/buku.SlackBuild
new file mode 100644
index 0000000000..054fb385e9
--- /dev/null
+++ b/desktop/buku/buku.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+#
+# Slackware build script for buku.
+#
+# Copyright 2018 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# Copyright 2019-2020 Andrew Clemons, Wellington New Zealand
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=buku
+VERSION=${VERSION:-4.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py build
+python3 setup.py install --root=$PKG --prefix=/usr --optimize=1
+
+install -Dm644 auto-completion/fish/buku.fish $PKG/usr/share/fish/vendor_completions.d/buku.fish
+install -Dm644 auto-completion/bash/buku-completion.bash $PKG/etc/bash_completion.d/buku
+install -Dm644 auto-completion/zsh/_buku $PKG/usr/share/zsh/site-functions/_buku
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+install -Dm 644 buku.1 $PKG/usr/man/man1/buku.1
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp CHANGELOG LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/buku/buku.info b/desktop/buku/buku.info
new file mode 100644
index 0000000000..a26761afb0
--- /dev/null
+++ b/desktop/buku/buku.info
@@ -0,0 +1,10 @@
+PRGNAM="buku"
+VERSION="4.3"
+HOMEPAGE="https://github.com/jarun/buku"
+DOWNLOAD="https://github.com/jarun/buku/archive/v4.3/buku-4.3.tar.gz"
+MD5SUM="eba8cbd7d31fb2cf0e25c1c8aa7661e3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-urllib3 BeautifulSoup4 cryptography html5lib python3-certifi"
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"
diff --git a/desktop/buku/slack-desc b/desktop/buku/slack-desc
new file mode 100644
index 0000000000..fdb4fe2fbc
--- /dev/null
+++ b/desktop/buku/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+buku: buku (Cmdline bookmark manager with editor and browser integration)
+buku:
+buku: buku is a powerful bookmark manager written in Python3 and SQLite3.
+buku: buku fetches the title of a bookmarked url and stores it along with
+buku: any user-provided comments and tags.
+buku:
+buku: Homepage: https://github.com/jarun/buku
+buku:
+buku:
+buku:
+buku: