summaryrefslogtreecommitdiffstats
path: root/desktop/devilspie
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2012-09-17 06:57:14 +0200
committer Robby Workman <rworkman@slackbuilds.org>2012-09-17 23:34:11 -0500
commitd067a23de62b13ff77615e2f6be7d66b533a7535 (patch)
tree437ee95dc366e168a3bd976ec8258bca6165f99b /desktop/devilspie
parentebb28e63159ed53e925bef0dbefcfd9aadfa382b (diff)
downloadslackbuilds-d067a23de62b13ff77615e2f6be7d66b533a7535.tar.gz
slackbuilds-d067a23de62b13ff77615e2f6be7d66b533a7535.tar.xz
desktop/devilspie: Fixed underlinking, cleanups.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'desktop/devilspie')
-rw-r--r--desktop/devilspie/devilspie.SlackBuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/desktop/devilspie/devilspie.SlackBuild b/desktop/devilspie/devilspie.SlackBuild
index 28e2e1990c..65b702b9a0 100644
--- a/desktop/devilspie/devilspie.SlackBuild
+++ b/desktop/devilspie/devilspie.SlackBuild
@@ -5,7 +5,7 @@
PRGNAM=devilspie
VERSION=0.22
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
@@ -56,6 +56,7 @@ find . \
sed -i -e '/-DG.*_DISABLE_DEPRECATED/d' src/Makefile.am
autoreconf
+LDFLAGS="-lX11" \
CFLAGS="$SLKCFLAGS" \
CPPFLAGS="$SLKCFLAGS" \
./configure \
@@ -68,13 +69,11 @@ CPPFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING README ChangeLog TODO $PKG/usr/doc/$PRGNAM-$VERSION