summaryrefslogtreecommitdiffstats
path: root/desktop/fbpanel
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2021-06-28 18:19:52 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-07-03 11:36:09 +0700
commit5bc164311c06f9b73d4046216b462c84c642577e (patch)
treeedc1363c18e53ebf86072a553660b1d033de8d01 /desktop/fbpanel
parent95b9114def335af8f13c1260683e9150b08e8f7a (diff)
downloadslackbuilds-5bc164311c06f9b73d4046216b462c84c642577e.tar.gz
slackbuilds-5bc164311c06f9b73d4046216b462c84c642577e.tar.xz
desktop/fbpanel: Updated for version 7.2, cleanups.
Switch to cmake, add a license Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop/fbpanel')
-rw-r--r--desktop/fbpanel/README10
-rw-r--r--desktop/fbpanel/fbpanel.SlackBuild65
-rw-r--r--desktop/fbpanel/fbpanel.info8
-rw-r--r--desktop/fbpanel/slack-desc8
4 files changed, 52 insertions, 39 deletions
diff --git a/desktop/fbpanel/README b/desktop/fbpanel/README
index e5aa37a87e..7bc4f666b4 100644
--- a/desktop/fbpanel/README
+++ b/desktop/fbpanel/README
@@ -1,5 +1,9 @@
fbpanel is a lightweight GTK2-based panel for UNIX desktop, which
provides graphical information and feedback about desktop activity
-and allows interaction with the window manager. It features a
-taskbar, pager, launchbar, show desktop, image viewer, clock, and
-system tray.
+and allows interaction with the window manager.
+It features a taskbar, pager, launchbar, show desktop, image viewer,
+clock, and system tray.
+
+This script packages the maintained fork available at
+
+https://github.com/eleksir/fbpanel
diff --git a/desktop/fbpanel/fbpanel.SlackBuild b/desktop/fbpanel/fbpanel.SlackBuild
index a2851cbe81..0cf8626ef9 100644
--- a/desktop/fbpanel/fbpanel.SlackBuild
+++ b/desktop/fbpanel/fbpanel.SlackBuild
@@ -9,10 +9,27 @@
# CONTACT: bzqwerty[at]gmail[dot]com #
######################################
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
# Modified by the SlackBuilds.org project
PRGNAM=fbpanel
-VERSION=${VERSION:-6.1}
+VERSION=${VERSION:-7.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -45,43 +62,35 @@ fi
set -e
-rm -rf $PKG $TMP/$PRGNAM-$VERSION
+rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-tar xvf $CWD/$PRGNAM-$VERSION.tbz2
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# --cxflags option don't work very well...
-sed -i "s|-O2 -Wall|$SLKCFLAGS -Wall|" rules.mk
-LIBSTOLINK="-lX11 -lgdk_pixbuf-2.0 -lgobject-2.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -lm"
-
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib$LIBDIRSUFFIX \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --host=$ARCH \
- --ldflagsx="$LIBSTOLINK" \
- --build=$ARCH-slackware-linux
-
-make
-make DESTDIR=$PKG install
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_MANDIR=/usr/man \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# Forgotten by the "make install"
-mkdir -p $PKG/usr/man/man1
-gzip -c data/man/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README CHANGELOG COPYING CREDITS NOTES $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.md COPYING CREDITS TODO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/desktop/fbpanel/fbpanel.info b/desktop/fbpanel/fbpanel.info
index 11ee61b441..1c79317e2d 100644
--- a/desktop/fbpanel/fbpanel.info
+++ b/desktop/fbpanel/fbpanel.info
@@ -1,8 +1,8 @@
PRGNAM="fbpanel"
-VERSION="6.1"
-HOMEPAGE="http://fbpanel.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/fbpanel/fbpanel-6.1.tbz2"
-MD5SUM="80ca0c64195b30587cfcb8c2cd9887a0"
+VERSION="7.2"
+HOMEPAGE="http://aanatoly.github.io/fbpanel/"
+DOWNLOAD="https://github.com/eleksir/fbpanel/archive/7.2/fbpanel-7.2.tar.gz"
+MD5SUM="b95677e7fb359739ca0e21ca64d4f2ba"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/desktop/fbpanel/slack-desc b/desktop/fbpanel/slack-desc
index fb0f3b9b21..0941d9bfd0 100644
--- a/desktop/fbpanel/slack-desc
+++ b/desktop/fbpanel/slack-desc
@@ -10,10 +10,10 @@ fbpanel: fbpanel (panel application)
fbpanel:
fbpanel: fbpanel is a lightweight GTK2-based panel for UNIX desktop, which
fbpanel: provides graphical information and feedback about desktop activity
-fbpanel: and allows interaction with the window manager. It features a
-fbpanel: taskbar, pager, launchbar, show desktop, image viewer, clock, and
-fbpanel: system tray.
+fbpanel: and allows interaction with the window manager.
+fbpanel: It features a taskbar, pager, launchbar, show desktop, image viewer,
+fbpanel: clock, and system tray.
fbpanel:
-fbpanel: http://fbpanel.sourceforge.net/
+fbpanel: homepage: http://aanatoly.github.io/fbpanel/
fbpanel:
fbpanel: