summaryrefslogtreecommitdiffstats
path: root/desktop/wmii/wmii.SlackBuild
diff options
context:
space:
mode:
author eroc <eroc@linuxmail.org>2010-05-11 19:44:09 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 19:44:09 +0200
commit40f0fe7514cb187e9f84d6d74626320b9cce5183 (patch)
treea3e37cf7d38c80eeec0947ffad0b3c96c0482489 /desktop/wmii/wmii.SlackBuild
parentf0786ec7dbca42862d44e65f40630eb317dd55fe (diff)
downloadslackbuilds-40f0fe7514cb187e9f84d6d74626320b9cce5183.tar.gz
slackbuilds-40f0fe7514cb187e9f84d6d74626320b9cce5183.tar.xz
desktop/wmii: Updated for version 3.5.1
Diffstat (limited to 'desktop/wmii/wmii.SlackBuild')
-rw-r--r--desktop/wmii/wmii.SlackBuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/desktop/wmii/wmii.SlackBuild b/desktop/wmii/wmii.SlackBuild
index 46ee5e49ad..7e82401fdb 100644
--- a/desktop/wmii/wmii.SlackBuild
+++ b/desktop/wmii/wmii.SlackBuild
@@ -11,7 +11,7 @@ VERSION=3.5.1
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-CWD=`pwd`
+CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -28,7 +28,6 @@ cd $TMP || exit 1
rm -rf $PRGNAM-$VERSION
tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
cd $PRGNAM-$VERSION || exit 1
-
chown -R root:root .
chmod -R a-s,u+rw,go-w .
@@ -38,15 +37,18 @@ sed -i s#'CONFPREFIX = ${PREFIX}/etc'#'CONFPREFIX = /etc/X11'# config.mk || exit
sed -i s#'MANPREFIX = ${PREFIX}/share/man'#'MANPREFIX = ${PREFIX}/man'# config.mk || exit 1
# Fix the CFLAGS
sed -i 's/CFLAGS = -Os /CFLAGS += /g' config.mk || exit 1
+
CFLAGS="$SLKCFLAGS" make || exit 1
make install DESTDIR=$PKG || exit 1
-find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
- for i in `find . -type l` ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+ for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION