summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-07-09 18:21:35 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-07-09 18:21:35 +0700
commit753465673170bbc2f735a0f59c1d0e8cb92a734f (patch)
tree98a279334d6d12bf731014fa55a22a93bf0f2ce1 /desktop
parent3ef0f47fe5277feacafc4dd86b37234ff2bd1e4c (diff)
downloadslackbuilds-753465673170bbc2f735a0f59c1d0e8cb92a734f.tar.gz
slackbuilds-753465673170bbc2f735a0f59c1d0e8cb92a734f.tar.xz
desktop/i3pystatus: Added (replacement for i3status).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/i3pystatus/README5
-rw-r--r--desktop/i3pystatus/doinst.sh3
-rw-r--r--desktop/i3pystatus/i3pystatus.SlackBuild86
-rw-r--r--desktop/i3pystatus/i3pystatus.info10
-rw-r--r--desktop/i3pystatus/slack-desc19
5 files changed, 123 insertions, 0 deletions
diff --git a/desktop/i3pystatus/README b/desktop/i3pystatus/README
new file mode 100644
index 0000000000..76ce0fed45
--- /dev/null
+++ b/desktop/i3pystatus/README
@@ -0,0 +1,5 @@
+i3pystatus is a (hopefully growing) collection of python scripts for
+status output compatible to i3status / i3bar of the i3 window manager.
+
+Note:
+Make sure you installed python3 before installing pysetuptools
diff --git a/desktop/i3pystatus/doinst.sh b/desktop/i3pystatus/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/desktop/i3pystatus/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/desktop/i3pystatus/i3pystatus.SlackBuild b/desktop/i3pystatus/i3pystatus.SlackBuild
new file mode 100644
index 0000000000..9576b16390
--- /dev/null
+++ b/desktop/i3pystatus/i3pystatus.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for i3pystatus
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=i3pystatus
+VERSION=${VERSION:-3.29}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/i3pystatus/i3pystatus.info b/desktop/i3pystatus/i3pystatus.info
new file mode 100644
index 0000000000..8dc7a5a72f
--- /dev/null
+++ b/desktop/i3pystatus/i3pystatus.info
@@ -0,0 +1,10 @@
+PRGNAM="i3pystatus"
+VERSION="3.29"
+HOMEPAGE="https://github.com/enkore/i3pystatus"
+DOWNLOAD="https://pypi.python.org/packages/source/i/i3pystatus/i3pystatus-3.29.tar.gz"
+MD5SUM="db7b1a505d66d41bbe5ddaf563ded250"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3 pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/desktop/i3pystatus/slack-desc b/desktop/i3pystatus/slack-desc
new file mode 100644
index 0000000000..e50eb9b704
--- /dev/null
+++ b/desktop/i3pystatus/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+i3pystatus: i3pystatus: (replacement for i3status)
+i3pystatus:
+i3pystatus: i3pystatus is a (hopefully growing) collection of python scripts
+i3pystatus: for status output compatible to i3status / i3bar of the i3 window
+i3pystatus: manager.
+i3pystatus:
+i3pystatus: Homepage: https://github.com/enkore/i3pystatus
+i3pystatus:
+i3pystatus:
+i3pystatus:
+i3pystatus: