summaryrefslogtreecommitdiffstats
path: root/development/beautysh
diff options
context:
space:
mode:
author Leo C <leoc@gmx.com>2018-01-21 07:05:29 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-01-27 07:43:46 +0700
commit56d1d7176f745c544d0e3e40aab222dc849becf8 (patch)
tree7cd39376f6336d949e6472b42e2ac31c173dc933 /development/beautysh
parentf34f0de85b6ab4d946d45442230b9e86635ad4b5 (diff)
downloadslackbuilds-56d1d7176f745c544d0e3e40aab222dc849becf8.tar.gz
slackbuilds-56d1d7176f745c544d0e3e40aab222dc849becf8.tar.xz
development/beautysh: Added (A Bash beautifier).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/beautysh')
-rw-r--r--development/beautysh/README2
-rw-r--r--development/beautysh/beautysh.SlackBuild83
-rw-r--r--development/beautysh/beautysh.info10
-rw-r--r--development/beautysh/slack-desc19
4 files changed, 114 insertions, 0 deletions
diff --git a/development/beautysh/README b/development/beautysh/README
new file mode 100644
index 0000000000..ed34e5c201
--- /dev/null
+++ b/development/beautysh/README
@@ -0,0 +1,2 @@
+This program takes upon itself the hard task of beautifying Bash
+scripts.
diff --git a/development/beautysh/beautysh.SlackBuild b/development/beautysh/beautysh.SlackBuild
new file mode 100644
index 0000000000..a18fbaf370
--- /dev/null
+++ b/development/beautysh/beautysh.SlackBuild
@@ -0,0 +1,83 @@
+#!/bin/sh
+
+# Slackware build script for beautysh
+
+# Copyright 2018 Leonardo Citrolo, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=beautysh
+VERSION=${VERSION:-3.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE MANIFEST README.md README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/beautysh/beautysh.info b/development/beautysh/beautysh.info
new file mode 100644
index 0000000000..25208caf66
--- /dev/null
+++ b/development/beautysh/beautysh.info
@@ -0,0 +1,10 @@
+PRGNAM="beautysh"
+VERSION="3.7"
+HOMEPAGE="https://github.com/bemeurer/beautysh"
+DOWNLOAD="https://github.com/bemeurer/beautysh/archive/3.7/beautysh-3.7.tar.gz"
+MD5SUM="44e2945a2e9226d110a90e1c3ef61a13"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Leo C."
+EMAIL="leoc@gmx.com"
diff --git a/development/beautysh/slack-desc b/development/beautysh/slack-desc
new file mode 100644
index 0000000000..6a6a16ea8e
--- /dev/null
+++ b/development/beautysh/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+beautysh: beautysh (A Bash beautifier for the masses)
+beautysh:
+beautysh: This program takes upon itself the hard task of beautifying Bash
+beautysh: scripts.
+beautysh:
+beautysh:
+beautysh:
+beautysh:
+beautysh:
+beautysh: Homepage: https://github.com/bemeurer/beautysh
+beautysh: