summaryrefslogtreecommitdiffstats
path: root/development/bpython
diff options
context:
space:
mode:
author vvoody <ydoovv@gmail.com>2010-05-13 00:57:49 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:57:49 +0200
commit517a64a12e50fcc851d22af10556e18311c5d9af (patch)
tree869a33658352f08788b0c55b97772b3e2231f8ab /development/bpython
parent5a78f85979e4e587b86231eaa1391aa35b76ff13 (diff)
downloadslackbuilds-517a64a12e50fcc851d22af10556e18311c5d9af.tar.gz
slackbuilds-517a64a12e50fcc851d22af10556e18311c5d9af.tar.xz
development/bpython: Added to 13.0 repository
Diffstat (limited to 'development/bpython')
-rw-r--r--development/bpython/README3
-rw-r--r--development/bpython/bpython.SlackBuild56
-rw-r--r--development/bpython/bpython.info10
-rw-r--r--development/bpython/doinst.sh9
-rw-r--r--development/bpython/slack-desc19
5 files changed, 97 insertions, 0 deletions
diff --git a/development/bpython/README b/development/bpython/README
new file mode 100644
index 0000000000..d3ec49eb09
--- /dev/null
+++ b/development/bpython/README
@@ -0,0 +1,3 @@
+bpython - A fancy curses interface to the Python interactive interpreter
+
+Requires: Pygments
diff --git a/development/bpython/bpython.SlackBuild b/development/bpython/bpython.SlackBuild
new file mode 100644
index 0000000000..754c6d92b8
--- /dev/null
+++ b/development/bpython/bpython.SlackBuild
@@ -0,0 +1,56 @@
+#!/bin/sh
+# Slackware build script for bpython
+
+# Written by vvoody <ydoovv@gmail.com>
+
+PRGNAM=bpython
+VERSION=${VERSION:-0.9.6.2}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+)
+
+mkdir -p ${PKG}/usr/doc/$PRGNAM-$VERSION
+
+cp -a \
+ PKG-INFO AUTHORS README CHANGELOG sample-config sample.theme light.theme \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mv $PKG/usr/share/man $PKG/usr
+find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/bpython/bpython.info b/development/bpython/bpython.info
new file mode 100644
index 0000000000..7d2e1493b9
--- /dev/null
+++ b/development/bpython/bpython.info
@@ -0,0 +1,10 @@
+PRGNAM="bpython"
+VERSION="0.9.6.2"
+HOMEPAGE="http://bpython-interpreter.org/"
+DOWNLOAD="http://bpython-interpreter.org/releases/bpython-0.9.6.2.tar.gz"
+DOWNLOAD_x86_64=""
+MD5SUM="d30fdb663fa9957c21c63108ed249b59"
+MD5SUM_x86_64=""
+MAINTAINER="vvoody"
+EMAIL="ydoovv@gmail.com"
+APPROVED="dsomero"
diff --git a/development/bpython/doinst.sh b/development/bpython/doinst.sh
new file mode 100644
index 0000000000..5bf84b4cdb
--- /dev/null
+++ b/development/bpython/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -r usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -q usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/development/bpython/slack-desc b/development/bpython/slack-desc
new file mode 100644
index 0000000000..d0a8b5c7a8
--- /dev/null
+++ b/development/bpython/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+bpython: bpython (Fancy Interface to the Python Interpreter)
+bpython:
+bpython: bpython is a fancy interface to the Python interpreter for Unix-like
+bpython: operating systems.
+bpython:
+bpython:
+bpython:
+bpython:
+bpython:
+bpython:
+bpython: