summaryrefslogtreecommitdiffstats
path: root/development/cc65
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2017-07-03 21:34:49 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-08 07:11:16 +0700
commit5cfdaa94ea6aee8456d376357f985441609fdfed (patch)
tree96fd8bc3420fa812878ab7a541d9f85b166e0bc5 /development/cc65
parente6adb88e65b49533a82a15260cf92f086a679450 (diff)
downloadslackbuilds-5cfdaa94ea6aee8456d376357f985441609fdfed.tar.gz
slackbuilds-5cfdaa94ea6aee8456d376357f985441609fdfed.tar.xz
development/cc65: Updated for version 2.16_20170630.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'development/cc65')
-rw-r--r--development/cc65/cc65.SlackBuild20
-rw-r--r--development/cc65/cc65.info6
-rw-r--r--development/cc65/git2targz.sh10
3 files changed, 24 insertions, 12 deletions
diff --git a/development/cc65/cc65.SlackBuild b/development/cc65/cc65.SlackBuild
index 43e5d6955c..4878b29fb5 100644
--- a/development/cc65/cc65.SlackBuild
+++ b/development/cc65/cc65.SlackBuild
@@ -6,6 +6,14 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20170703 bkw:
+# - Update for 2.16_20170630. Upstream still hasn't done a release, but
+# again there's lots of development.
+# - My self-hosted source tarball now includes the HTML documentation. This
+# script used to build it, but -current's linuxdoc-tools chokes on it,
+# and fixing it would require me a week or two probably. So, for now
+# anyway, the tarball includes docs that were built on 14.2.
+
# 20170129 bkw:
# - Update for v2.15_20170126, aka git 6878ede. Upstream hasn't done
# a release since 2013 or so, but there's been lots of development.
@@ -14,7 +22,7 @@
# reason. Source is created from a git checkout, see git2targz.sh.
PRGNAM=cc65
-VERSION=${VERSION:-2.15_20170126}
+VERSION=${VERSION:-2.16_20170630}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -54,17 +62,11 @@ find . -type f -print0 | xargs -0 chmod 644
find . -type d -print0 | xargs -0 chmod 755
# external CFLAGS not honored
-sed -i "/^CFLAGS/s,-O,$SLKCFLAGS," src/Makefile
-
-# If we wanted GNU info docs, we could 'make doc' instead of 'make -C doc
-# html'. But, they're the same as the HTML pages, and they install into
-# /usr/info with names like 'intro' and 'index', which would be confusing.
-# It would be possible to patch things so we had 'cc65-intro', etc,
-# but IMO not worth the effort.
+sed -i "/^CFLAGS/s,-O[^ ]*,$SLKCFLAGS," src/Makefile
PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
make all prefix=/usr LDFLAGS=-Wl,-s
-make -C doc html
+#make -C doc html # we use pre-generated HTML docs now
make install prefix=$PKG/usr htmldir=$PKGDOC samplesdir=$PKGDOC/samples
# binaries already stripped, no man pages
diff --git a/development/cc65/cc65.info b/development/cc65/cc65.info
index ab1be6e0b9..0268de1d32 100644
--- a/development/cc65/cc65.info
+++ b/development/cc65/cc65.info
@@ -1,8 +1,8 @@
PRGNAM="cc65"
-VERSION="2.15_20170126"
+VERSION="2.16_20170630"
HOMEPAGE="http://cc65.github.io/cc65/"
-DOWNLOAD="http://urchlay.naptime.net/~urchlay/src/cc65-2.15_20170126.tar.xz"
-MD5SUM="59be82081cd44d50d170773d32839b22"
+DOWNLOAD="http://urchlay.naptime.net/~urchlay/src/cc65-2.16_20170630.tar.xz"
+MD5SUM="d939f05f3d3aa80f7ed9c17e9a28de39"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/development/cc65/git2targz.sh b/development/cc65/git2targz.sh
index c86e2d9412..68c19ebad6 100644
--- a/development/cc65/git2targz.sh
+++ b/development/cc65/git2targz.sh
@@ -38,6 +38,16 @@ VERSION=${MAJOR}.${MINOR}_$DATE
rm -rf .git
find . -name .gitignore -print0 | xargs -0 rm -f
+# DIRTY HACK ALERT:
+# -current's linuxdoc-tools hates upstream's sgml docs, and it's not
+# obvious what's wrong (bug/regression in linuxdoc-tools? 14.2's worked
+# fine). I'm not interested in trying to fix the problem because I
+# fucking hate XML, and I especially hate the mess that's the Slackware
+# linuxdoc-tools (28 source tarballs, interdependent). So I'll just
+# include pre-generated (on 14.2) HTML docs in my self-hosted source
+# tarball.
+make -C doc html
+
cd "$CWD"
rm -rf $PRGNAM-$VERSION $PRGNAM-$VERSION.tar.xz
mv $GITDIR $PRGNAM-$VERSION