summaryrefslogtreecommitdiffstats
path: root/development/osc
diff options
context:
space:
mode:
author Andrew Psaltis <ampsaltis@gmail.com>2010-05-12 23:28:45 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-12 23:28:45 +0200
commit84691416a0f4ea80f28a04eed4df1192427a80df (patch)
tree619bc734db84539315dcc08787ad48f0910d0f14 /development/osc
parent0721894431cf5291d49446dc36bf7dbb19c7ec41 (diff)
downloadslackbuilds-84691416a0f4ea80f28a04eed4df1192427a80df.tar.gz
slackbuilds-84691416a0f4ea80f28a04eed4df1192427a80df.tar.xz
development/osc: Added to 12.2 repository
Diffstat (limited to 'development/osc')
-rw-r--r--development/osc/README9
-rw-r--r--development/osc/osc.SlackBuild65
-rw-r--r--development/osc/osc.info8
-rw-r--r--development/osc/slack-desc19
4 files changed, 101 insertions, 0 deletions
diff --git a/development/osc/README b/development/osc/README
new file mode 100644
index 0000000000..8e8dbbf924
--- /dev/null
+++ b/development/osc/README
@@ -0,0 +1,9 @@
+osc is a subversion-like client to the the OpenSUSE Build Service. It
+serves as client for the source code repository part of the build
+service, and it can be used to edit metadata, query about build
+results, and do virtually everything (and more) accessible from the web
+interface.
+
+On first run, osc will prompt you for your OpenSUSE Build Service credentials,
+and store them plaintext in ~/.oscrc. Guard the file and filesystem
+appropriately.
diff --git a/development/osc/osc.SlackBuild b/development/osc/osc.SlackBuild
new file mode 100644
index 0000000000..0e7268e926
--- /dev/null
+++ b/development/osc/osc.SlackBuild
@@ -0,0 +1,65 @@
+#!/bin/sh
+
+# Slackware build script for osc
+
+# Copyright 2009 Andrew Psaltis <ampsaltis@gmail.com>
+# All rights reserved.
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=osc
+VERSION=0.117
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xfv $CWD/${PRGNAM}_${VERSION}.orig.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Link the "wrapper" to the actual application name
+ln -s $PKG/usr/bin/osc-wrapper.py $PKG/usr/bin/osc
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS README NEWS \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/osc/osc.info b/development/osc/osc.info
new file mode 100644
index 0000000000..b4aa532754
--- /dev/null
+++ b/development/osc/osc.info
@@ -0,0 +1,8 @@
+PRGNAM="osc"
+VERSION="0.117"
+HOMEPAGE="http://en.opensuse.org/Osc"
+DOWNLOAD="http://slackbuilds.org/sources/12.2/osc_0.117.orig.tar.gz"
+MD5SUM="4ae751e5e8ceb64d57c95b93d032e89e"
+MAINTAINER="Andrew Psaltis"
+EMAIL="ampsaltis@gmail.com"
+APPROVED="rworkman"
diff --git a/development/osc/slack-desc b/development/osc/slack-desc
new file mode 100644
index 0000000000..3ac56a0d47
--- /dev/null
+++ b/development/osc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler--------------------------------------------------------------|
+osc: osc (command line interface to the OpenSUSE Build Service)
+osc:
+osc: osc is a subversion-like client to the OpenSUSE Build Service.
+osc: It serves as client for the source code repository part of the
+osc: build service, and it can be used to edit metadata, query about
+osc: build results, and do virtually everything accessible from the
+osc: web interface.
+osc:
+osc: Home page: http://en.opensuse.org/Build_Service/CLI
+osc:
+osc: