summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2010-05-22 22:53:20 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-05-23 23:21:42 -0500
commit097ac22cba2648b4f9e1c641d2a1d489d512de51 (patch)
tree6c754a4161bde69669494d8ef1cdfc0382f0e64b /development
parent424569da883126ac16f8ea9ea9d176ec0c1c02f2 (diff)
downloadslackbuilds-097ac22cba2648b4f9e1c641d2a1d489d512de51.tar.gz
slackbuilds-097ac22cba2648b4f9e1c641d2a1d489d512de51.tar.xz
development/bzr: Updated for version 2.1.0.
Diffstat (limited to 'development')
-rw-r--r--development/bzr/bzr.SlackBuild23
-rw-r--r--development/bzr/bzr.info6
2 files changed, 19 insertions, 10 deletions
diff --git a/development/bzr/bzr.SlackBuild b/development/bzr/bzr.SlackBuild
index bf99342577..fbd20796e4 100644
--- a/development/bzr/bzr.SlackBuild
+++ b/development/bzr/bzr.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for bzr
-# Copyright 2006-2010 Robby Workman Northport, AL, USA
+# Copyright 2006,2007,2008,2009,2010 Robby Workman Northport, AL, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,11 +23,20 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=bzr
-VERSION=2.0.3
-ARCH=${ARCH:-i486}
+VERSION=2.1.0
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -42,6 +51,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
set -e
@@ -66,10 +78,7 @@ python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
diff --git a/development/bzr/bzr.info b/development/bzr/bzr.info
index c08dbe1f41..dc56658e22 100644
--- a/development/bzr/bzr.info
+++ b/development/bzr/bzr.info
@@ -1,8 +1,8 @@
PRGNAM="bzr"
-VERSION="2.0.3"
+VERSION="2.1.0"
HOMEPAGE="http://bazaar-vcs.org/"
-DOWNLOAD="http://launchpad.net/bzr/2.0/2.0.3/+download/bzr-2.0.3.tar.gz"
-MD5SUM="60758e61b3fd3686966d7ab0ea17fa64"
+DOWNLOAD="http://launchpad.net/bzr/2.1/2.1.0/+download/bzr-2.1.0.tar.gz"
+MD5SUM="ea184d6cfb22cf4e92ee275f593ca88d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Robby Workman"