summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2018-03-07 08:39:10 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-10 07:11:07 +0700
commitfbc64cf9f84481cee4f844f259ac9e6b75aa3046 (patch)
treefc9e9acca1f592f755ba6bad3bdd615d2d8006c7 /development
parentffca7650cff20a71dd6edddb0a89e3d4e2edfa0c (diff)
downloadslackbuilds-fbc64cf9f84481cee4f844f259ac9e6b75aa3046.tar.gz
slackbuilds-fbc64cf9f84481cee4f844f259ac9e6b75aa3046.tar.xz
development/psycopg2: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'development')
-rw-r--r--development/psycopg2/psycopg2.SlackBuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/development/psycopg2/psycopg2.SlackBuild b/development/psycopg2/psycopg2.SlackBuild
index 56814b8e14..e7acad4154 100644
--- a/development/psycopg2/psycopg2.SlackBuild
+++ b/development/psycopg2/psycopg2.SlackBuild
@@ -58,6 +58,9 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true