summaryrefslogtreecommitdiffstats
path: root/games/defendguin
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2010-05-12 23:29:15 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:29:15 +0200
commite8259575a4e93bcd88cc8eeb4019d4532337d8b9 (patch)
tree09e5358cd39dbb15fe9cd5259a5257636473a2dd /games/defendguin
parent66110dd26e421661e8fd69fccf3777564b866307 (diff)
downloadslackbuilds-e8259575a4e93bcd88cc8eeb4019d4532337d8b9.tar.gz
slackbuilds-e8259575a4e93bcd88cc8eeb4019d4532337d8b9.tar.xz
games/defendguin: Added to 12.2 repository
Diffstat (limited to 'games/defendguin')
-rw-r--r--games/defendguin/README3
-rw-r--r--games/defendguin/defendguin.SlackBuild64
-rw-r--r--games/defendguin/defendguin.desktop6
-rw-r--r--games/defendguin/defendguin.info8
-rw-r--r--games/defendguin/defendguin.pngbin0 -> 2677 bytes
-rw-r--r--games/defendguin/doinst.sh5
-rw-r--r--games/defendguin/install_paths.diff53
-rw-r--r--games/defendguin/man.diff14
-rw-r--r--games/defendguin/slack-desc19
9 files changed, 172 insertions, 0 deletions
diff --git a/games/defendguin/README b/games/defendguin/README
new file mode 100644
index 0000000000..230724d2dd
--- /dev/null
+++ b/games/defendguin/README
@@ -0,0 +1,3 @@
+Defendguin is a clone of the arcade game "Defender," but with a Linux
+theme. Your mission is to defend little penguinoids from being captured
+and mutated.
diff --git a/games/defendguin/defendguin.SlackBuild b/games/defendguin/defendguin.SlackBuild
new file mode 100644
index 0000000000..1cd7d04cab
--- /dev/null
+++ b/games/defendguin/defendguin.SlackBuild
@@ -0,0 +1,64 @@
+#!/bin/sh
+
+# Slackware build script for defendguin
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+PRGNAM=defendguin
+VERSION=${VERSION:-0.0.11}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod 755 .
+chmod -R a-s,u+w,go+r-w .
+
+patch -p1 < $CWD/install_paths.diff
+patch -p1 < $CWD/man.diff
+
+make COPT="$SLKCFLAGS"
+make install DESTDIR=$PKG
+
+# Cruft removal:
+rm -f \
+ $PKG/usr/share/$PRGNAM/images/l2r.sh \
+ $PKG/usr/share/$PRGNAM/images/loader/loading-orig.bmp.gz
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp docs/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/usr/share/applications
+cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+
+mkdir -p $PKG/usr/share/pixmaps
+cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/games/defendguin/defendguin.desktop b/games/defendguin/defendguin.desktop
new file mode 100644
index 0000000000..b01a0adcea
--- /dev/null
+++ b/games/defendguin/defendguin.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Name=Defendguin
+Exec=defendguin
+Type=Application
+Icon=defendguin
+Categories=Game;
diff --git a/games/defendguin/defendguin.info b/games/defendguin/defendguin.info
new file mode 100644
index 0000000000..1bcee3b837
--- /dev/null
+++ b/games/defendguin/defendguin.info
@@ -0,0 +1,8 @@
+PRGNAM="defendguin"
+VERSION="0.0.11"
+HOMEPAGE="http://www.newbreedsoftware.com/defendguin/"
+DOWNLOAD="ftp://ftp.tuxpaint.org/unix/x/defendguin/src/defendguin-0.0.11.tar.gz"
+MD5SUM="c8040e39f199c5338625066025ec2395"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
+APPROVED="dsomero"
diff --git a/games/defendguin/defendguin.png b/games/defendguin/defendguin.png
new file mode 100644
index 0000000000..1d76e94219
--- /dev/null
+++ b/games/defendguin/defendguin.png
Binary files differ
diff --git a/games/defendguin/doinst.sh b/games/defendguin/doinst.sh
new file mode 100644
index 0000000000..c3651bc867
--- /dev/null
+++ b/games/defendguin/doinst.sh
@@ -0,0 +1,5 @@
+
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/games/defendguin/install_paths.diff b/games/defendguin/install_paths.diff
new file mode 100644
index 0000000000..602aa4b325
--- /dev/null
+++ b/games/defendguin/install_paths.diff
@@ -0,0 +1,53 @@
+diff -Naur defendguin-0.0.11/Makefile defendguin-0.0.11.patched/Makefile
+--- defendguin-0.0.11/Makefile 2006-01-29 04:23:31.000000000 -0500
++++ defendguin-0.0.11.patched/Makefile 2009-04-16 03:18:04.000000000 -0400
+@@ -9,11 +9,12 @@
+
+ # User-definable stuff:
+
+-CFLAGS=-Wall -O2
++DESTDIR=
++COPT=
+ #DATA_PREFIX=$(PWD)/data/
+-PREFIX=/usr/local
++PREFIX=/usr
+ MAN_PREFIX=$(PREFIX)
+-BIN_PREFIX=$(PREFIX)/bin
++BIN_PREFIX=$(PREFIX)/games
+ DATA_PREFIX=$(PREFIX)/share/defendguin/
+ JOY=YES
+
+@@ -24,7 +25,7 @@
+ SDL_LDFLAGS := $(shell sdl-config --libs) -L/usr/X11R6/lib
+ MIXER=-lSDL_mixer
+ NOSOUNDFLAG=__SOUND
+-CFLAGS=-Wall $(SDL_CFLAGS) -DDATA_PREFIX=\"$(DATA_PREFIX)\" -D$(NOSOUNDFLAG) \
++CFLAGS=-Wall $(COPT) $(SDL_CFLAGS) -DDATA_PREFIX=\"$(DATA_PREFIX)\" -D$(NOSOUNDFLAG) \
+ -DJOY_$(JOY)
+ SDL_LIB=$(SDL_LDFLAGS) $(MIXER)
+
+@@ -37,13 +38,17 @@
+ make defendguin MIXER= NOSOUNDFLAG=NOSOUND
+
+ install: defendguin
+- install -d $(DATA_PREFIX)
+- cp -R data/* $(DATA_PREFIX)
+- chmod -R a+rX,g-w,o-w $(DATA_PREFIX)
+- cp defendguin $(BIN_PREFIX)/
+- chmod a+rx,g-w,o-w $(BIN_PREFIX)/defendguin
+- cp src/defendguin.6 $(MAN_PREFIX)/man/man6/
+- chmod a+rx,g-w,o-w $(MAN_PREFIX)/man/man6/defendguin.6
++ install -d $(DESTDIR)$(DATA_PREFIX)
++ install -d $(DESTDIR)$(MAN_PREFIX)/man/man6/
++ install -d $(DESTDIR)$(BIN_PREFIX)
++ cp -R data/* $(DESTDIR)$(DATA_PREFIX)
++ chmod -R a+rX,g-w,o-w $(DESTDIR)$(DATA_PREFIX)
++ strip defendguin
++ cp defendguin $(DESTDIR)$(BIN_PREFIX)/
++ chmod a+rx,g-w,o-w $(DESTDIR)$(BIN_PREFIX)/defendguin
++ cp src/defendguin.6 $(DESTDIR)$(MAN_PREFIX)/man/man6/
++ chmod a+rx,g-w,o-w $(DESTDIR)$(MAN_PREFIX)/man/man6/defendguin.6
++ gzip -9 $(DESTDIR)$(MAN_PREFIX)/man/man6/defendguin.6
+
+ uninstall:
+ -rm -r $(DATA_PREFIX)
diff --git a/games/defendguin/man.diff b/games/defendguin/man.diff
new file mode 100644
index 0000000000..1c306e39d9
--- /dev/null
+++ b/games/defendguin/man.diff
@@ -0,0 +1,14 @@
+diff -Naur defendguin-0.0.11/src/defendguin.6 defendguin-0.0.11.patched/src/defendguin.6
+--- defendguin-0.0.11/src/defendguin.6 2006-01-29 05:16:58.000000000 -0500
++++ defendguin-0.0.11.patched/src/defendguin.6 2009-04-16 03:27:29.000000000 -0400
+@@ -29,7 +29,9 @@
+ \fB\-\-usage\fR
+ Displays acceptable command\-line options.
+ .SH "FILES"
+-\fI/usr/local/share/defendguin/\fP \- Sound, music and graphics data.
++\fI/usr/share/defendguin/\fP \- Sound, music and graphics data.
++.LP
++\fI~/.defendguinrc\fP \- Per\-user settings
+ .LP
+ .SH "AUTHORS"
+ .LP
diff --git a/games/defendguin/slack-desc b/games/defendguin/slack-desc
new file mode 100644
index 0000000000..9cd96d80e7
--- /dev/null
+++ b/games/defendguin/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+defendguin: defendguin (clone of the arcade game Defender)
+defendguin:
+defendguin: Defendguin is a clone of the arcade game "Defender," but with a
+defendguin: Linux theme. Your mission is to defend little penguinoids from
+defendguin: being captured and mutated.
+defendguin:
+defendguin:
+defendguin:
+defendguin:
+defendguin:
+defendguin: