summaryrefslogtreecommitdiffstats
path: root/games/yabause
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-02-21 13:35:08 -0500
committer Robby Workman <rworkman@slackbuilds.org>2022-02-21 14:34:28 -0600
commit04fd195fb5728f5b72bc8c3f0ba335ff84bf4210 (patch)
treed22c54b919dc1d980019ba2631f5c6de9968673f /games/yabause
parenta5039932aeedf8ef448e62c0855d61a6f2a5a4cd (diff)
downloadslackbuilds-04fd195fb5728f5b72bc8c3f0ba335ff84bf4210.tar.gz
slackbuilds-04fd195fb5728f5b72bc8c3f0ba335ff84bf4210.tar.xz
games/yabause: Fix 15.0 build.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'games/yabause')
-rw-r--r--games/yabause/README6
-rw-r--r--games/yabause/yabause.SlackBuild16
2 files changed, 9 insertions, 13 deletions
diff --git a/games/yabause/README b/games/yabause/README
index 4bba665f10..4401f14ad6 100644
--- a/games/yabause/README
+++ b/games/yabause/README
@@ -11,11 +11,5 @@ Yabause is a Sega Saturn emulator. It has the following features:
Optional dependencies: gtkglext, mini18n
-By default the QT version of yabause is built. To use the GTK
-version, first install gtkglext then pass USE_GUI=gtk to the
-slackbuild:
-
- USE_GUI=gtk ./yabause.SlackBuild
-
Before using Yabause, you need to configure a few things in
the Preferences dialog (File>Settings).
diff --git a/games/yabause/yabause.SlackBuild b/games/yabause/yabause.SlackBuild
index a3e6b94a6e..c7b82f73eb 100644
--- a/games/yabause/yabause.SlackBuild
+++ b/games/yabause/yabause.SlackBuild
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220221 bkw: Modified by SlackBuilds.org:
+# - fix build on 15.0, by always building with gtk instead of qt.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=yabause
VERSION=${VERSION:-0.9.15}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,12 +75,14 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# Variable to determine gtk/qt interface. Default is qt.
-USE_GUI=${USE_GUI:-qt}
+# 20220221 bkw: hardcoded to gtk, because qt won't build on Slackware 15.0.
+# Possibly it would with qt4, but not qt5.
+USE_GUI=gtk
# Fix location of man file.
sed -i 's|share/man|man|' src/CMakeLists.txt