summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Damian Perticone <mjolnirdam@gmail.com>2022-06-07 11:48:09 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-06-11 08:59:00 +0700
commit20bcacc3773c7034d8a50b71db85e496ee9160d2 (patch)
treedcdb8d7b9d6bcd0f42d0cc4bdec3b44af372dfbf /games
parent293070304947de0c80eac8f87b240d406c1a31af (diff)
downloadslackbuilds-20bcacc3773c7034d8a50b71db85e496ee9160d2.tar.gz
slackbuilds-20bcacc3773c7034d8a50b71db85e496ee9160d2.tar.xz
games/protonup: Added (cli proton-GE updater)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/protonup/README57
-rw-r--r--games/protonup/protonup.SlackBuild93
-rw-r--r--games/protonup/protonup.info10
-rw-r--r--games/protonup/slack-desc19
4 files changed, 179 insertions, 0 deletions
diff --git a/games/protonup/README b/games/protonup/README
new file mode 100644
index 0000000000..cd578bc957
--- /dev/null
+++ b/games/protonup/README
@@ -0,0 +1,57 @@
+Set your installation directory before running the program with -d
+"your/compatibilitytools.d/directory"
+
+Example:
+
+protonup -d "~/.steam/root/compatibilitytools.d/"
+
+To update to the latest version, just run protonup from a command line
+
+Example:
+
+protonup
+
+List available versions with --releases
+
+Example:
+
+protonup --releases
+
+Install a specific version with -t "version tag"
+
+Example:
+
+protonup -t 6.5-GE-2
+
+By default the downloads are stored in a temporary folder.
+Change it with -o "custom/download/directory"
+
+Example:
+
+protonup -o ~/Downloads
+
+List existing installations with -l
+
+Example:
+
+protonup -l
+
+Remove existing installations with -r "version tag
+
+Example:
+
+protonup -r 6.5-GE-2
+
+Use --download to download Proton-GE to the current working directory
+without installing it, you can override destination with -o
+
+Example:
+
+protonup --download
+
+Use -y toggle to carry out actions without any logging or interaction
+
+Example:
+
+protonup --download -o ~/Downloads -y
+
diff --git a/games/protonup/protonup.SlackBuild b/games/protonup/protonup.SlackBuild
new file mode 100644
index 0000000000..f1e5c8d4f2
--- /dev/null
+++ b/games/protonup/protonup.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/bash
+
+# Slackware build script for protonup
+
+# Copyright 2022 Damian Perticone, Berisso, Argentina
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=protonup
+VERSION=${VERSION:-0.1.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/games/protonup/protonup.info b/games/protonup/protonup.info
new file mode 100644
index 0000000000..f234d94a22
--- /dev/null
+++ b/games/protonup/protonup.info
@@ -0,0 +1,10 @@
+PRGNAM="protonup"
+VERSION="0.1.4"
+HOMEPAGE="https://github.com/AUNaseef/protonup"
+DOWNLOAD="https://github.com/AUNaseef/protonup/archive/0.1.4/protonup-0.1.4.tar.gz"
+MD5SUM="419caee4f61967d4f1fd7e29372456f2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Damian Perticone"
+EMAIL="mjolnirdam@gmail.com"
diff --git a/games/protonup/slack-desc b/games/protonup/slack-desc
new file mode 100644
index 0000000000..f35e913ab5
--- /dev/null
+++ b/games/protonup/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+protonup: protonup (cli proton-GE updater)
+protonup:
+protonup: Protonup is a CLI program and API to automate the installation and
+protonup: update of GloriousEggroll's Proton-GE.
+protonup:
+protonup:
+protonup:
+protonup:
+protonup:
+protonup: Home: https://github.com/AUNaseef/protonup
+protonup: