summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Damian Perticone <mjolnirdam@gmail.com>2022-04-09 11:32:53 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-09 15:45:53 +0700
commit5639480c1872795e76c286c93ccc986d77f97f1e (patch)
treef2489f6ba4c6a1e1cf97e57106306ce178bc558a /games
parentfbb7d786635d7b0325badc7e23207f576d42e78c (diff)
downloadslackbuilds-5639480c1872795e76c286c93ccc986d77f97f1e.tar.gz
slackbuilds-5639480c1872795e76c286c93ccc986d77f97f1e.tar.xz
games/protontricks: Added (winetricks wrapper for proton).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/protontricks/README10
-rw-r--r--games/protontricks/doint.sh3
-rw-r--r--games/protontricks/protontricks-1.8.0_no-setuptools-scm.patch.gzbin0 -> 583 bytes
-rw-r--r--games/protontricks/protontricks.SlackBuild94
-rw-r--r--games/protontricks/protontricks.info10
-rw-r--r--games/protontricks/slack-desc19
6 files changed, 136 insertions, 0 deletions
diff --git a/games/protontricks/README b/games/protontricks/README
new file mode 100644
index 0000000000..1319d02490
--- /dev/null
+++ b/games/protontricks/README
@@ -0,0 +1,10 @@
+This is a wrapper script that allows you to easily run Winetricks
+commands for Steam Play/Proton games among other common Wine features,
+such as launching external Windows executables.
+This is often useful when a game requires closed-source runtime
+libraries or applications that are not included with
+Proton.
+
+requires winetricks to work
+optional dependencies="yad" for GUI for game selection
+ "zenity" for GUI for winetricks
diff --git a/games/protontricks/doint.sh b/games/protontricks/doint.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/games/protontricks/doint.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/games/protontricks/protontricks-1.8.0_no-setuptools-scm.patch.gz b/games/protontricks/protontricks-1.8.0_no-setuptools-scm.patch.gz
new file mode 100644
index 0000000000..373624e461
--- /dev/null
+++ b/games/protontricks/protontricks-1.8.0_no-setuptools-scm.patch.gz
Binary files differ
diff --git a/games/protontricks/protontricks.SlackBuild b/games/protontricks/protontricks.SlackBuild
new file mode 100644
index 0000000000..a7b0d899f3
--- /dev/null
+++ b/games/protontricks/protontricks.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/bash
+
+# Slackware build script for protontricks
+
+# Copyright 2022 Damian Perticone Berisso,Argentina
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=protontricks
+VERSION=${VERSION:-1.8.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+zcat $CWD/protontricks-1.8.0_no-setuptools-scm.patch | patch -p1 || exit
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/games/protontricks/protontricks.info b/games/protontricks/protontricks.info
new file mode 100644
index 0000000000..8e017ac407
--- /dev/null
+++ b/games/protontricks/protontricks.info
@@ -0,0 +1,10 @@
+PRGNAM="protontricks"
+VERSION="1.8.1"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+DOWNLOAD="https://github.com/Matoking/protontricks/archive/refs/tags/1.8.1/protontricks-1.8.1.tar.gz"
+MD5SUM="d2d4347a5c4b56c642ee5fa4355ea916"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Damian Perticone"
+EMAIL="mjolnirdam@gmail.com"
diff --git a/games/protontricks/slack-desc b/games/protontricks/slack-desc
new file mode 100644
index 0000000000..267c925126
--- /dev/null
+++ b/games/protontricks/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+protontricks: protontricks (winetricks wrapper for proton)
+protontricks:
+protontricks: Protontricks is a wrapper that runs Winetricks commands for Proton
+protontricks: enabled games among other useful features
+protontricks:
+protontricks:
+protontricks: More info: https://github.com/Matoking/protontricks
+protontricks:
+protontricks:
+protontricks:
+protontricks: