summaryrefslogtreecommitdiffstats
path: root/gis/gj2ascii/gj2ascii.SlackBuild
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2021-03-28 02:58:18 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-04-03 08:48:27 +0700
commitf1a280698731eaf5cdfc94aabfb2110460b5a63d (patch)
tree1fa9b7648778994ae7f1332b89df1f62cc35372d /gis/gj2ascii/gj2ascii.SlackBuild
parentc574e45943fd1554410f9e5a630c27931617527d (diff)
downloadslackbuilds-f1a280698731eaf5cdfc94aabfb2110460b5a63d.tar.gz
slackbuilds-f1a280698731eaf5cdfc94aabfb2110460b5a63d.tar.xz
gis/gj2ascii: Update for Python 3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis/gj2ascii/gj2ascii.SlackBuild')
-rw-r--r--gis/gj2ascii/gj2ascii.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/gis/gj2ascii/gj2ascii.SlackBuild b/gis/gj2ascii/gj2ascii.SlackBuild
index aa5b014afa..fc4ce03bcb 100644
--- a/gis/gj2ascii/gj2ascii.SlackBuild
+++ b/gis/gj2ascii/gj2ascii.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for gj2ascii
-# Copyright 2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2018-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=gj2ascii
VERSION=${VERSION:-0.4.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true