summaryrefslogtreecommitdiffstats
path: root/graphics/HotShots
diff options
context:
space:
mode:
author Andrey Maraev <andrew.maraev60@yandex.ru>2013-10-20 17:32:23 +0200
committer Matteo Bernardini <ponce@slackbuilds.org>2013-10-23 12:17:44 +0200
commit1efbf2c1e6a41dd9fdc82cb3c00ac30d960e8cb9 (patch)
treebb7f90421d19222e1c1b2b55b06c888e69573874 /graphics/HotShots
parent0d9d6ba32d286c8e5bba04530c3fd4e154a58d88 (diff)
downloadslackbuilds-1efbf2c1e6a41dd9fdc82cb3c00ac30d960e8cb9.tar.gz
slackbuilds-1efbf2c1e6a41dd9fdc82cb3c00ac30d960e8cb9.tar.xz
graphics/Hotshots: Added (screenshot tool).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'graphics/HotShots')
-rw-r--r--graphics/HotShots/HotShots.SlackBuild106
-rw-r--r--graphics/HotShots/HotShots.info10
-rw-r--r--graphics/HotShots/README3
-rw-r--r--graphics/HotShots/doinst.sh7
-rw-r--r--graphics/HotShots/slack-desc19
5 files changed, 145 insertions, 0 deletions
diff --git a/graphics/HotShots/HotShots.SlackBuild b/graphics/HotShots/HotShots.SlackBuild
new file mode 100644
index 0000000000..fa9fce2819
--- /dev/null
+++ b/graphics/HotShots/HotShots.SlackBuild
@@ -0,0 +1,106 @@
+#!/bin/sh
+
+# Slackware build script for HotShots
+
+# Copyright 2013 Andrey Maraev <andrew.maraev60@yandex.ru>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=HotShots
+VERSION=${VERSION:-1.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix translations path
+cd $TMP/$PRGNAM-$VERSION/src
+sed -i "s!/usr/local/share/locale!/usr/share/hotshots/lang!g" MiscFunctions.cpp
+sed -i "s!/usr/share/local/locale!/usr/share/hotshots/lang!g" MiscFunctions.cpp
+cd $TMP/$PRGNAM-$VERSION/build
+sed -i "s!share/locale!share/hotshots/lang!g" CMakeLists.txt
+
+# Fix libqxt include path
+sed -i "s!/usr/include/qxt/!/usr/include/!g" CMakeLists.txt
+
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release .
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING.txt FAQ.txt NEWS.txt CREDITS.txt INSTALL.txt \
+ README.txt AUTHORS.txt Changelog.txt LICENSE.txt TODO.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/HotShots/HotShots.info b/graphics/HotShots/HotShots.info
new file mode 100644
index 0000000000..cf595011c8
--- /dev/null
+++ b/graphics/HotShots/HotShots.info
@@ -0,0 +1,10 @@
+PRGNAM="HotShots"
+VERSION="1.2.1"
+HOMEPAGE="http://sourceforge.net/projects/hotshots"
+DOWNLOAD="http://downloads.sf.net/hotshots/HotShots-1.2.1.zip"
+MD5SUM="a114a062f99c93e7a4fac18582625f4d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="libqxt"
+MAINTAINER="Andrey Maraev"
+EMAIL="andrew.maraev60@yandex.ru"
diff --git a/graphics/HotShots/README b/graphics/HotShots/README
new file mode 100644
index 0000000000..41dead6ff8
--- /dev/null
+++ b/graphics/HotShots/README
@@ -0,0 +1,3 @@
+HotShots is an application for capturing screens and saving them
+in a variety of image formats as well as adding annotations and
+graphical data (arrows, lines, texts, ...).
diff --git a/graphics/HotShots/doinst.sh b/graphics/HotShots/doinst.sh
new file mode 100644
index 0000000000..9a8ded3c60
--- /dev/null
+++ b/graphics/HotShots/doinst.sh
@@ -0,0 +1,7 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
diff --git a/graphics/HotShots/slack-desc b/graphics/HotShots/slack-desc
new file mode 100644
index 0000000000..26420a88ee
--- /dev/null
+++ b/graphics/HotShots/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+HotShots: Hotshots (screenshot tool)
+HotShots:
+HotShots: HotShots is an application for capturing screens and saving them
+HotShots: in a variety of image formats as well as adding annotations and
+HotShots: graphical data (arrows, lines, texts, ...).
+HotShots:
+HotShots: homepage - http://sourceforge.net/projects/hotshots
+HotShots:
+HotShots:
+HotShots:
+HotShots: