summaryrefslogtreecommitdiffstats
path: root/libraries/COLAMD/autotoolize.diff
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2011-06-17 21:57:48 -0400
committer Robby Workman <rworkman@slackbuilds.org>2011-06-19 23:17:04 -0500
commitc376c25b968111b41827e287377dfd139800a9f8 (patch)
tree6b965daa6dddf38c62a1189fdda48d6b65b88c3a /libraries/COLAMD/autotoolize.diff
parentbc3878e3a4ee264c248f17e8ffc94a771caf03b7 (diff)
downloadslackbuilds-c376c25b968111b41827e287377dfd139800a9f8.tar.gz
slackbuilds-c376c25b968111b41827e287377dfd139800a9f8.tar.xz
libraries/COLAMD: Updated for version 2.7.3.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries/COLAMD/autotoolize.diff')
-rw-r--r--libraries/COLAMD/autotoolize.diff52
1 files changed, 42 insertions, 10 deletions
diff --git a/libraries/COLAMD/autotoolize.diff b/libraries/COLAMD/autotoolize.diff
index 331f0d1722..c9c43d2a1e 100644
--- a/libraries/COLAMD/autotoolize.diff
+++ b/libraries/COLAMD/autotoolize.diff
@@ -3,7 +3,7 @@ new file mode 100644
--- /dev/null
+++ b/Demo/Makefile.am
@@ -0,0 +1,31 @@
-+AM_CPPFLAGS = -I$(top_srcdir)/Include
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
+LDADD = $(top_builddir)/Source/libcolamd.la
+
+EXTRA_DIST = \
@@ -34,20 +34,29 @@ new file mode 100644
+
+clean-local:
+ -$(RM) my_*.out
+diff --git a/Include/Makefile.am b/Include/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Include/Makefile.am
+@@ -0,0 +1,2 @@
++pkgincludedir = $(includedir)/colamd
++pkginclude_HEADERS = colamd.h
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Makefile.am
-@@ -0,0 +1,3 @@
-+SUBDIRS = Source Demo
+@@ -0,0 +1,5 @@
++SUBDIRS = Include Source Demo
+EXTRA_DIST = README.txt Doc/ChangeLog Doc/lesser.txt
-+include_HEADERS = Include/colamd.h
++
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = colamd.pc
diff --git a/Source/Makefile.am b/Source/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Source/Makefile.am
@@ -0,0 +1,18 @@
-+AM_CPPFLAGS = -I$(top_builddir)/Include
++AM_CPPFLAGS = -I$(top_builddir)/Include $(UFCONFIG_CFLAGS)
+
+COLAMDSRC = \
+ colamd.c
@@ -64,14 +73,31 @@ new file mode 100644
+
+libcolamd_la_SOURCES = colamd_global.c
+libcolamd_la_LIBADD = libcolamdi.la libcolamdl.la
-+libcolamd_la_LDFLAGS = -no-undefined -version-info 9:2:7
++libcolamd_la_LDFLAGS = -no-undefined -version-info 9:3:7
+diff --git a/colamd.pc.in b/colamd.pc.in
+new file mode 100644
+--- /dev/null
++++ b/colamd.pc.in
+@@ -0,0 +1,12 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: @PACKAGE_NAME@
++Description: Column approximate minimum degree ordering
++Version: @PACKAGE_VERSION@
++Requires.private: ufconfig
++Libs: -L${libdir} -lcolamd
++Libs.private: -lm
++Cflags: -I${includedir}/colamd
diff --git a/configure.ac b/configure.ac
new file mode 100644
--- /dev/null
+++ b/configure.ac
-@@ -0,0 +1,28 @@
-+AC_PREREQ([2.65])
-+AC_INIT([COLAMD], [2.7.2], [davis@cise.ufl.edu])
+@@ -0,0 +1,34 @@
++AC_PREREQ([2.68])
++AC_INIT([COLAMD],[2.7.3],[davis@cise.ufl.edu])
+AC_CONFIG_SRCDIR([Source/colamd_global.c])
+AC_CONFIG_HEADER([config.h])
+AM_INIT_AUTOMAKE([foreign])
@@ -85,7 +111,11 @@ new file mode 100644
+AC_CHECK_LIB([m], [sqrt])
+
+AC_CHECK_HEADERS([limits.h stdlib.h])
-+AC_CHECK_HEADERS([UFconfig.h])
++
++PKG_PROG_PKG_CONFIG
++PKG_CHECK_MODULES([UFCONFIG],[ufconfig],
++ [],
++ [AC_MSG_ERROR([cannot find ufconfig])])
+
+AC_TYPE_SIZE_T
+
@@ -94,7 +124,9 @@ new file mode 100644
+LIBS=$LIBS_SAVED
+
+AC_CONFIG_FILES([
++ colamd.pc
+ Makefile
+ Demo/Makefile
++ Include/Makefile
+ Source/Makefile])
+AC_OUTPUT