summaryrefslogtreecommitdiffstats
path: root/libraries/PyXML
diff options
context:
space:
mode:
author Alex Lysenka <me@alkos333.net>2010-05-11 20:00:41 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:00:41 +0200
commit42a906630638262b17233c895194cf8830d04aac (patch)
tree9b53a547762a3b89b70d7316d76b4a520bf2dbf6 /libraries/PyXML
parentaf7b3ada6c60f7ddd5da837b3e24091a16e8907e (diff)
downloadslackbuilds-42a906630638262b17233c895194cf8830d04aac.tar.gz
slackbuilds-42a906630638262b17233c895194cf8830d04aac.tar.xz
libraries/PyXML: Added to 12.0 repository
Diffstat (limited to 'libraries/PyXML')
-rw-r--r--libraries/PyXML/PyXML.SlackBuild78
-rw-r--r--libraries/PyXML/PyXML.info8
-rw-r--r--libraries/PyXML/README5
-rw-r--r--libraries/PyXML/slack-desc19
4 files changed, 110 insertions, 0 deletions
diff --git a/libraries/PyXML/PyXML.SlackBuild b/libraries/PyXML/PyXML.SlackBuild
new file mode 100644
index 0000000000..853b2a70c4
--- /dev/null
+++ b/libraries/PyXML/PyXML.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/sh
+
+# Slackware build script for PyXML
+
+# Copyright (c) 2007 Alex Lysenka <me@alkos333.net>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Modified by Robby Workman <rworkman@slackbuilds.org>
+# No additional license terms
+
+PRGNAM=PyXML
+VERSION=0.8.4
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py build
+python setup.py install --prefix=/usr --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/man/man1
+cp $TMP/$PRGNAM-$VERSION/doc/man/* $PKG/usr/man/man1
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+
+cp -a ANNOUNCE CREDITS LICENCE MANIFEST PKG-INFO README* TODO demo doc \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/PyXML/PyXML.info b/libraries/PyXML/PyXML.info
new file mode 100644
index 0000000000..e06f75a6db
--- /dev/null
+++ b/libraries/PyXML/PyXML.info
@@ -0,0 +1,8 @@
+PRGNAM="PyXML"
+VERSION="0.8.4"
+HOMEPAGE="http://pyxml.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/pyxml/PyXML-0.8.4.tar.gz"
+MD5SUM="1f7655050cebbb664db976405fdba209"
+MAINTAINER="Alex Lysenka"
+EMAIL="me@alkos333.net"
+APPROVED="rworkman"
diff --git a/libraries/PyXML/README b/libraries/PyXML/README
new file mode 100644
index 0000000000..6d8f2ee977
--- /dev/null
+++ b/libraries/PyXML/README
@@ -0,0 +1,5 @@
+This is the Python XML package. The distribution contains a
+validating XML parser, an implementation of the SAX and DOM
+programming interfaces, an interface to the Expat parser (and the
+Expat parser itself), and a C helper module that can speed up
+xmllib.py by a factor of 5
diff --git a/libraries/PyXML/slack-desc b/libraries/PyXML/slack-desc
new file mode 100644
index 0000000000..d52179da19
--- /dev/null
+++ b/libraries/PyXML/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+PyXML: PyXML (Python XML package)
+PyXML:
+PyXML: This is the Python XML package. The distribution contains a
+PyXML: validating XML parser, an implementation of the SAX and DOM
+PyXML: programming interfaces, an interface to the Expat parser (and the
+PyXML: Expat parser itself), and a C helper module that can speed up
+PyXML: xmllib.py by a factor of 5
+PyXML:
+PyXML: Homepage: http://pyxml.sourceforge.net/
+PyXML:
+PyXML: