summaryrefslogtreecommitdiffstats
path: root/libraries/frei0r
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2018-03-14 20:55:55 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-17 08:51:54 +0700
commit0336cfede35dbf39ffe2b2471e2aafd99c0518fa (patch)
tree3c91ae1d8373ce338059c22938ce19a879f4c92d /libraries/frei0r
parent2cfb9543ff85f3f003b97c7875adad1a9e1e5669 (diff)
downloadslackbuilds-0336cfede35dbf39ffe2b2471e2aafd99c0518fa.tar.gz
slackbuilds-0336cfede35dbf39ffe2b2471e2aafd99c0518fa.tar.xz
libraries/frei0r: Updated for version 1.6.1, cleanups.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries/frei0r')
-rw-r--r--libraries/frei0r/fix_building_against_opencv_3.0.patch52
-rw-r--r--libraries/frei0r/frei0r.SlackBuild11
-rw-r--r--libraries/frei0r/frei0r.info6
3 files changed, 11 insertions, 58 deletions
diff --git a/libraries/frei0r/fix_building_against_opencv_3.0.patch b/libraries/frei0r/fix_building_against_opencv_3.0.patch
deleted file mode 100644
index b9dd1352f4..0000000000
--- a/libraries/frei0r/fix_building_against_opencv_3.0.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff -up ./frei0r-plugins-1.4/src/filter/facedetect/facedetect.c.opencv3 ./frei0r-plugins-1.4/src/filter/facedetect/facedetect.c
---- ./frei0r-plugins-1.4/src/filter/facedetect/facedetect.c.opencv3 2013-02-24 14:43:22.000000000 +0100
-+++ ./frei0r-plugins-1.4/src/filter/facedetect/facedetect.c 2015-07-08 12:44:30.987056878 +0200
-@@ -211,8 +211,8 @@ CvSeq* detect_and_draw( IplImage* img, C
-
- double scale = 1.3;
- IplImage* gray = cvCreateImage( cvSize(img->width,img->height), 8, 1 );
-- IplImage* small_img = cvCreateImage( cvSize( cvRound (img->width/scale),
-- cvRound (img->height/scale)),
-+ IplImage* small_img = cvCreateImage( cvSize( cvRound ((double)img->width/scale),
-+ cvRound ((double)img->height/scale)),
- 8, 1 );
- int i;
-
-diff -up ./frei0r-plugins-1.4/src/filter/facedetect/facedetect.cpp.opencv3 ./frei0r-plugins-1.4/src/filter/facedetect/facedetect.cpp
---- ./frei0r-plugins-1.4/src/filter/facedetect/facedetect.cpp.opencv3 2013-02-24 14:43:22.000000000 +0100
-+++ ./frei0r-plugins-1.4/src/filter/facedetect/facedetect.cpp 2015-07-08 12:48:32.754615885 +0200
-@@ -259,11 +259,11 @@ private:
- {
- double scale = this->scale == 0? 1.0 : this->scale;
- CvScalar colors[5] = {
-- {{cvRound(color[0].r * 255), cvRound(color[0].g * 255), cvRound(color[0].b * 255), cvRound(alpha * 255)}},
-- {{cvRound(color[1].r * 255), cvRound(color[1].g * 255), cvRound(color[1].b * 255), cvRound(alpha * 255)}},
-- {{cvRound(color[2].r * 255), cvRound(color[2].g * 255), cvRound(color[2].b * 255), cvRound(alpha * 255)}},
-- {{cvRound(color[3].r * 255), cvRound(color[3].g * 255), cvRound(color[3].b * 255), cvRound(alpha * 255)}},
-- {{cvRound(color[4].r * 255), cvRound(color[4].g * 255), cvRound(color[4].b * 255), cvRound(alpha * 255)}},
-+ CvScalar(cvRound(color[0].r * 255), cvRound(color[0].g * 255), cvRound(color[0].b * 255), cvRound(alpha * 255)),
-+ CvScalar(cvRound(color[1].r * 255), cvRound(color[1].g * 255), cvRound(color[1].b * 255), cvRound(alpha * 255)),
-+ CvScalar(cvRound(color[2].r * 255), cvRound(color[2].g * 255), cvRound(color[2].b * 255), cvRound(alpha * 255)),
-+ CvScalar(cvRound(color[3].r * 255), cvRound(color[3].g * 255), cvRound(color[3].b * 255), cvRound(alpha * 255)),
-+ CvScalar(cvRound(color[4].r * 255), cvRound(color[4].g * 255), cvRound(color[4].b * 255), cvRound(alpha * 255)),
- };
-
- for (int i = 0; i < (objects ? objects->total : 0); i++)
-@@ -287,14 +287,14 @@ private:
- }
- case 1:
- {
-- CvBox2D box = {{center.x, center.y}, {r->width / scale, (r->height / scale) * 1.2}, 90};
-+ CvBox2D box = CvBox2D(CvPoint2D32f(center.x, center.y), CvSize2D32f(r->width / scale, (r->height / scale) * 1.2), 90);
- cvEllipseBox(image, box, colors[i % 5], thickness, linetype);
- break;
- }
- case 2:
- {
-- CvPoint pt1 = {r->x / scale, r->y / scale};
-- CvPoint pt2 = {(r->x + r->width) / scale, (r->y + r->height) / scale};
-+ CvPoint pt1 = CvPoint(r->x / scale, r->y / scale);
-+ CvPoint pt2 = CvPoint((r->x + r->width) / scale, (r->y + r->height) / scale);
- cvRectangle(image, pt1, pt2, colors[i % 5], thickness, linetype);
- break;
- }
diff --git a/libraries/frei0r/frei0r.SlackBuild b/libraries/frei0r/frei0r.SlackBuild
index 17ca0093ff..875cac4bc0 100644
--- a/libraries/frei0r/frei0r.SlackBuild
+++ b/libraries/frei0r/frei0r.SlackBuild
@@ -4,7 +4,7 @@
# Copyright 2009, Jonathan Larsen (agentc0re), SLC, UT
# Contact Info: agentc0re 'AT' learnix 'DOT' net
-# Copyright 2012-2017 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2012-2018 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -37,9 +37,11 @@
# *Updated for 1.5.0
# May 25th, 2017
# *Updated for 1.6.0
+# Mar 14th, 2018
+# *Updated for 1.6.1
PRGNAM=frei0r
-VERSION=${VERSION:-1.6.0}
+VERSION=${VERSION:-1.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -86,7 +88,10 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix installation paths
-sed -i -e "s|lib/|lib$LIBDIRSUFFIX/|" -e "s|lib\"|lib$LIBDIRSUFFIX\"|" CMakeLists.txt
+sed -i \
+ -e "s|lib/|lib$LIBDIRSUFFIX/|" \
+ -e "s|lib\"|lib$LIBDIRSUFFIX\"|" \
+ CMakeLists.txt || exit 1
mkdir -p build
cd build
diff --git a/libraries/frei0r/frei0r.info b/libraries/frei0r/frei0r.info
index 76f3a453a9..efe8bab51f 100644
--- a/libraries/frei0r/frei0r.info
+++ b/libraries/frei0r/frei0r.info
@@ -1,8 +1,8 @@
PRGNAM="frei0r"
-VERSION="1.6.0"
+VERSION="1.6.1"
HOMEPAGE="http://frei0r.dyne.org"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/frei0r-plugins-1.6.0.tar.gz"
-MD5SUM="c93eaa8e9cd010249c986f388499b6f6"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/frei0r-plugins-1.6.1.tar.gz"
+MD5SUM="bb85573340029e5d0ae1c21d0685461d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""