summaryrefslogtreecommitdiffstats
path: root/libraries/hinnant-date/CMakeLists.txt
diff options
context:
space:
mode:
author Andre Barboza <bmg.andre@gmail.com>2016-12-16 23:38:32 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-17 01:18:30 +0700
commit70531054c49799ca9eb1820470c73f122652cdd1 (patch)
tree572d0022edcb59e0212124b453fb8d72ce4272ed /libraries/hinnant-date/CMakeLists.txt
parentcb538f7e0479a5495f6459bb1031831056d51c73 (diff)
downloadslackbuilds-70531054c49799ca9eb1820470c73f122652cdd1.tar.gz
slackbuilds-70531054c49799ca9eb1820470c73f122652cdd1.tar.xz
libraries/hinnant-date: Added (A date and time library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/hinnant-date/CMakeLists.txt')
-rw-r--r--libraries/hinnant-date/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/libraries/hinnant-date/CMakeLists.txt b/libraries/hinnant-date/CMakeLists.txt
new file mode 100644
index 0000000000..de22fa388b
--- /dev/null
+++ b/libraries/hinnant-date/CMakeLists.txt
@@ -0,0 +1,25 @@
+cmake_minimum_required(VERSION 3.2)
+
+project(date)
+set(LIBRARY_SHARED_OR_STATIC STATIC)
+
+set(header_files
+ date.h
+ tz.h tz_private.h
+ chrono_io.h
+ iso_week.h
+ julian.h
+ islamic.h)
+
+set(source_files
+ tz.cpp)
+
+add_library(${PROJECT_NAME} ${LIBRARY_SHARED_OR_STATIC} ${header_files} ${souce_files})
+set_target_properties(${PROJECT_NAME} PROPERTIES LINKER_LANGUAGE CXX)
+
+install(TARGETS ${PROJECT_NAME} DESTINATION lib${LIB_SUFFIX})
+install(FILES ${header_files} DESTINATION include)
+
+configure_file("libdate.pc.in" "libdate.pc" @ONLY)
+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libdate.pc"
+ DESTINATION "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}/pkgconfig")