summaryrefslogtreecommitdiffstats
path: root/libraries/lablgtk
diff options
context:
space:
mode:
author fdeak <ferenc.deak@gmail.com>2010-05-11 14:56:16 +0200
committer Michiel van Wessem <michiel@slackbuilds.org>2010-05-11 14:56:16 +0200
commit05e492f455764e7e68ac90ea9afc1c5285980b98 (patch)
treec97a50102f848b7bf8bf157c6276c5339a4fa786 /libraries/lablgtk
parent8f153419eec105c7070bd3dd4156c65ff10991b9 (diff)
downloadslackbuilds-05e492f455764e7e68ac90ea9afc1c5285980b98.tar.gz
slackbuilds-05e492f455764e7e68ac90ea9afc1c5285980b98.tar.xz
libraries/lablgtk: Initial import
Diffstat (limited to 'libraries/lablgtk')
-rw-r--r--libraries/lablgtk/README19
-rw-r--r--libraries/lablgtk/lablgtk.SlackBuild55
-rw-r--r--libraries/lablgtk/lablgtk.info8
-rw-r--r--libraries/lablgtk/slack-desc11
4 files changed, 93 insertions, 0 deletions
diff --git a/libraries/lablgtk/README b/libraries/lablgtk/README
new file mode 100644
index 0000000000..4b92f392af
--- /dev/null
+++ b/libraries/lablgtk/README
@@ -0,0 +1,19 @@
+LablGTK is an Objective Caml interface to gtk+/gtk+-2
+
+It uses the rich type system of Objective Caml 3 to provide a strongly typed,
+yet very comfortable, object-oriented interface to gtk+. This is not that easy
+if you know the dynamic typing approach taken by gtk+.
+
+It is still under development, but already fully functional. All widgets (but
+one) are available, with almost all their methods. The GLArea widget is also
+supported in combination with LablGL. LibGlade and GdkPixbuf support is also
+included for both versions. LablGTK2 adds support for gnomecanvas, librsvg and
+libpanel Many examples are provided.
+
+Objective Caml threads are supported, including for the toplevel, which allows
+for interactive use of the library. Since release 1.2.1, LablGTK contains
+support for rapid development with glade, through an interface wrapper compiler,
+and a libglade binding. You can also find code generators in the tools section.
+
+You need an ocaml compiler (available on http://slackbuilds.org) to use and/or
+to compile.
diff --git a/libraries/lablgtk/lablgtk.SlackBuild b/libraries/lablgtk/lablgtk.SlackBuild
new file mode 100644
index 0000000000..00461eccba
--- /dev/null
+++ b/libraries/lablgtk/lablgtk.SlackBuild
@@ -0,0 +1,55 @@
+#!/bin/sh
+
+# Slackware build script for lablgtk
+# Written by fdeak <ferenc.deak@gmail.com>
+
+set -e
+
+PRGNAM=lablgtk
+VERSION=2.6.0
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xzf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+./configure --prefix=/usr
+sed -i -e "s/\\(CFLAGS = .*\\)/\\1 ${SLKCFLAGS}/" src/Makefile
+sed -i -e "s/\\(CFLAGS += -O\\)/CFLAGS +=/" src/Makefile
+make world
+make DESTDIR=$PKG install
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES CHANGES.API COPYING README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+
+
diff --git a/libraries/lablgtk/lablgtk.info b/libraries/lablgtk/lablgtk.info
new file mode 100644
index 0000000000..da935acfbb
--- /dev/null
+++ b/libraries/lablgtk/lablgtk.info
@@ -0,0 +1,8 @@
+PRGNAM="lablgtk"
+VERSION="2.6.0"
+HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/lsl/lablgtk.html"
+DOWNLOAD="http://wwwfun.kurims.kyoto-u.ac.jp/soft/lsl/dist/lablgtk-2.6.0.tar.gz"
+MD5SUM="47319aacbbb761323bdfab67513829df"
+MAINTAINER="fdeak"
+EMAIL="ferenc.deak@gmail.com"
+APPROVED="BP{k}" \ No newline at end of file
diff --git a/libraries/lablgtk/slack-desc b/libraries/lablgtk/slack-desc
new file mode 100644
index 0000000000..e35f79c958
--- /dev/null
+++ b/libraries/lablgtk/slack-desc
@@ -0,0 +1,11 @@
+lablgtk: LablGTK (an Objective Caml interface to gtk+/gtk+-2)
+lablgtk:
+lablgtk: LablGTK uses the rich type system of Objective Caml 3 to provide a
+lablgtk: strongly typed, yet very comfortable, object-oriented interface to
+lablgtk: gtk+.
+lablgtk:
+lablgtk: It is still under development, but already fully functional. All
+lablgtk: widgets (but one) are available, with almost all their methods. The
+lablgtk: GLArea widget is also supported in combination with LablGL. LibGlade
+lablgtk: and GdkPixbuf support is also included for both versions. LablGTK2
+lablgtk: adds support for gnomecanvas, librsvg and libpanel.