summaryrefslogtreecommitdiffstats
path: root/libraries/libzrtpcpp
diff options
context:
space:
mode:
author Mauro Giachero <mauro dot giachero at gmail dot com>2010-05-12 23:30:47 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:30:47 +0200
commitf4cd4156cf1cb6852fb889bef8a710ac048b8c92 (patch)
treeb36341bb0b6783c37651b4d6eccac0050a25c82d /libraries/libzrtpcpp
parentba01f403905f5460bf0e3896414f4ae467e49152 (diff)
downloadslackbuilds-f4cd4156cf1cb6852fb889bef8a710ac048b8c92.tar.gz
slackbuilds-f4cd4156cf1cb6852fb889bef8a710ac048b8c92.tar.xz
libraries/libzrtpcpp: Added to 12.2 repository
Diffstat (limited to 'libraries/libzrtpcpp')
-rw-r--r--libraries/libzrtpcpp/README11
-rw-r--r--libraries/libzrtpcpp/libzrtpcpp.SlackBuild91
-rw-r--r--libraries/libzrtpcpp/libzrtpcpp.info8
-rw-r--r--libraries/libzrtpcpp/slack-desc20
4 files changed, 130 insertions, 0 deletions
diff --git a/libraries/libzrtpcpp/README b/libraries/libzrtpcpp/README
new file mode 100644
index 0000000000..9f55d8a5d7
--- /dev/null
+++ b/libraries/libzrtpcpp/README
@@ -0,0 +1,11 @@
+GNU ZRTP is a C++ implementation of Phil Zimmermann's ZRTP
+specification and is available under the GPL license.
+
+The complete GNU ZRTP implementation consists of two main parts,
+the GNU ZRTP core (independent from the OS and the RTP/SRTP
+implementation) and an RTP/SRTP implementation specific glue code.
+The current GNU ZRTP distribution contains glue code to bind GNU ZRTP
+to GNU ccRTP.
+
+This package requires commoncpp2 and ccrtp, both available on
+SlackBuilds.org.
diff --git a/libraries/libzrtpcpp/libzrtpcpp.SlackBuild b/libraries/libzrtpcpp/libzrtpcpp.SlackBuild
new file mode 100644
index 0000000000..7e9bf67f25
--- /dev/null
+++ b/libraries/libzrtpcpp/libzrtpcpp.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for libzrtpcpp
+
+# Copyright 2008 Mauro Giachero (mauro dot giachero at gmail dot com)
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libzrtpcpp
+VERSION=${VERSION:-1.4.3}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
+
+make
+make install DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/* demo [A-LN-Z]* $PKG/usr/doc/$PRGNAM-$VERSION
+# Remove stale Makefiles
+rm -f $PKG/usr/doc/$PRGNAM-$VERSION/Makefile*
+# Remove static libraries
+rm $PKG/usr/lib/*a
+# Fix documentation permissions
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
+find $PKG/usr/doc/$PRGNAM-$VERSION -type d -exec chmod 755 {} \;
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/libzrtpcpp/libzrtpcpp.info b/libraries/libzrtpcpp/libzrtpcpp.info
new file mode 100644
index 0000000000..4c7c1171bb
--- /dev/null
+++ b/libraries/libzrtpcpp/libzrtpcpp.info
@@ -0,0 +1,8 @@
+PRGNAM="libzrtpcpp"
+VERSION="1.4.3"
+HOMEPAGE="http://www.gnutelephony.org/"
+DOWNLOAD="http://www.gnutelephony.org/dist/archive/libzrtpcpp-1.4.3.tar.gz"
+MD5SUM="84386a596578a7c0c92c7b999a7f16f0"
+MAINTAINER="Mauro Giachero"
+EMAIL="mauro dot giachero at gmail dot com"
+APPROVED="dsomero"
diff --git a/libraries/libzrtpcpp/slack-desc b/libraries/libzrtpcpp/slack-desc
new file mode 100644
index 0000000000..6999be2c4f
--- /dev/null
+++ b/libraries/libzrtpcpp/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+libzrtpcpp: ZRTP (C++ implementation of Phil Zimmermann's ZRTP)
+libzrtpcpp:
+libzrtpcpp: GNU ZRTP is a C++ implementation of Phil Zimmermann's ZRTP
+libzrtpcpp: specification and is available under the GPL license.
+libzrtpcpp:
+libzrtpcpp: The complete GNU ZRTP implementation consists of two main parts,
+libzrtpcpp: the GNU ZRTP core (independent from the OS and the RTP/SRTP
+libzrtpcpp: implementation) and an RTP/SRTP implementation specific glue code.
+libzrtpcpp: The current GNU ZRTP distribution contains glue code to bind GNU
+libzrtpcpp: ZRTP to GNU ccRTP.
+libzrtpcpp: Homepage: http://www.gnutelephony.org/
+