summaryrefslogtreecommitdiffstats
path: root/libraries/newt
diff options
context:
space:
mode:
author Marco Bonetti <sid77@slackware.it>2010-08-13 07:23:49 -0500
committer Erik Hanson <erik@slackbuilds.org>2010-08-14 19:04:49 -0500
commit700d2413a949ab13235cb87e72300d124af49692 (patch)
tree236249dfe62eef66bf1da6f4965f2c647ada3dfb /libraries/newt
parente3fe37cbfe4ea9c081c7fed654bbaf1125f6689d (diff)
downloadslackbuilds-700d2413a949ab13235cb87e72300d124af49692.tar.gz
slackbuilds-700d2413a949ab13235cb87e72300d124af49692.tar.xz
libraries/newt: Added (graphic library)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'libraries/newt')
-rw-r--r--libraries/newt/README4
-rw-r--r--libraries/newt/newt.SlackBuild105
-rw-r--r--libraries/newt/newt.info10
-rw-r--r--libraries/newt/slack-desc19
-rw-r--r--libraries/newt/tcl85.diff10
5 files changed, 148 insertions, 0 deletions
diff --git a/libraries/newt/README b/libraries/newt/README
new file mode 100644
index 0000000000..d8f818fe11
--- /dev/null
+++ b/libraries/newt/README
@@ -0,0 +1,4 @@
+Newt is a programming library for color text mode, widget based user
+interfaces. Newt can be used to add stacked windows, entry widgets,
+checkboxes, radio buttons, labels, plain text fields, scrollbars, etc., to
+text mode user interfaces. Newt is based on the S-Lang library.
diff --git a/libraries/newt/newt.SlackBuild b/libraries/newt/newt.SlackBuild
new file mode 100644
index 0000000000..8260d81d75
--- /dev/null
+++ b/libraries/newt/newt.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/sh
+
+# Slackware build script for Newt.
+#
+# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=newt
+VERSION=${VERSION:-0.52.11}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="CHANGES COPYING"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+# Use TCL 8.5
+patch -p1 < $CWD/tcl85.diff
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --build=$ARCH-slackware-linux
+
+make
+make install instroot=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/newt/newt.info b/libraries/newt/newt.info
new file mode 100644
index 0000000000..e7a11da408
--- /dev/null
+++ b/libraries/newt/newt.info
@@ -0,0 +1,10 @@
+PRGNAM="newt"
+VERSION="0.52.11"
+HOMEPAGE="https://fedorahosted.org/newt/"
+DOWNLOAD="https://fedorahosted.org/releases/n/e/newt/newt-0.52.11.tar.gz"
+MD5SUM="4b9a0685ecd180c42d2c4a5806e3fc52"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="Erik Hanson"
diff --git a/libraries/newt/slack-desc b/libraries/newt/slack-desc
new file mode 100644
index 0000000000..2a43453ea2
--- /dev/null
+++ b/libraries/newt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+newt: Newt (graphic library)
+newt:
+newt: Newt is a programming library for color text mode, widget based user
+newt: interfaces.
+newt:
+newt:
+newt:
+newt:
+newt:
+newt: https://fedorahosted.org/newt/
+newt:
diff --git a/libraries/newt/tcl85.diff b/libraries/newt/tcl85.diff
new file mode 100644
index 0000000000..958c4d1b0b
--- /dev/null
+++ b/libraries/newt/tcl85.diff
@@ -0,0 +1,10 @@
+diff -Naur newt-0.52.11.orig/Makefile.in newt-0.52.11/Makefile.in
+--- newt-0.52.11.orig/Makefile.in 2009-09-24 17:03:09.000000000 +0200
++++ newt-0.52.11/Makefile.in 2010-07-20 10:19:28.246709110 +0200
+@@ -1,5 +1,5 @@
+ LIBS = -lslang
+-LIBTCL = -ltcl8.4
++LIBTCL = -ltcl8.5
+
+ CC = @CC@
+ CPP = @CPP@