summaryrefslogtreecommitdiffstats
path: root/libraries/nltk
diff options
context:
space:
mode:
author Marco Bonetti <sid77@slackware.it>2010-05-12 23:30:53 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:30:53 +0200
commitd94661631010085d5ba5899e7ad1e30b54bae56e (patch)
treecefd0a504371dd0c618b670de70698f36c7f7dd9 /libraries/nltk
parent1d4dc4d54f5cd17078b391e5bc70c61ebed286f2 (diff)
downloadslackbuilds-d94661631010085d5ba5899e7ad1e30b54bae56e.tar.gz
slackbuilds-d94661631010085d5ba5899e7ad1e30b54bae56e.tar.xz
libraries/nltk: Added to 12.2 repository
Diffstat (limited to 'libraries/nltk')
-rw-r--r--libraries/nltk/README7
-rw-r--r--libraries/nltk/nltk.SlackBuild72
-rw-r--r--libraries/nltk/nltk.info8
-rw-r--r--libraries/nltk/slack-desc19
4 files changed, 106 insertions, 0 deletions
diff --git a/libraries/nltk/README b/libraries/nltk/README
new file mode 100644
index 0000000000..89a521107d
--- /dev/null
+++ b/libraries/nltk/README
@@ -0,0 +1,7 @@
+Open source Python modules, linguistic data and documentation for research
+and development in natural language processing, supporting dozens of NLP
+tasks, with distributions for Windows, Mac OSX and Linux.
+
+NLTK comes with many corpora, toy grammars, trained models, etc. A complete
+list is posted at: http://nltk.googlecode.com/svn/trunk/nltk_data/index.xml
+To retrieve all the data, use "python -m nltk.downloader all".
diff --git a/libraries/nltk/nltk.SlackBuild b/libraries/nltk/nltk.SlackBuild
new file mode 100644
index 0000000000..0c8da3420d
--- /dev/null
+++ b/libraries/nltk/nltk.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for nltk.
+#
+# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=nltk
+VERSION=0.9.8
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="LICENSE.txt PKG-INFO README.txt"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+ python setup.py bdist
+tar zxvf dist/$PRGNAM-$VERSION.linux-i686.tar.gz -C $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/nltk/nltk.info b/libraries/nltk/nltk.info
new file mode 100644
index 0000000000..a1c411a264
--- /dev/null
+++ b/libraries/nltk/nltk.info
@@ -0,0 +1,8 @@
+PRGNAM="nltk"
+VERSION="0.9.8"
+HOMEPAGE="http://www.nltk.org/"
+DOWNLOAD="http://nltk.googlecode.com/files/nltk-0.9.8.tar.gz"
+MD5SUM="954f614754a0d7cb58c83b5ec485ddda"
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="dsomero"
diff --git a/libraries/nltk/slack-desc b/libraries/nltk/slack-desc
new file mode 100644
index 0000000000..884a5bfeb8
--- /dev/null
+++ b/libraries/nltk/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+nltk: nltk (Natural Language ToolKit)
+nltk:
+nltk: Open source Python modules, linguistic data and documentation for
+nltk: research and development in natural language processing, supporting
+nltk: dozens of NLP tasks, with distributions for Windows, Mac OSX and
+nltk: Linux.
+nltk:
+nltk:
+nltk:
+nltk:
+nltk: