summaryrefslogtreecommitdiffstats
path: root/libraries/zsi
diff options
context:
space:
mode:
author Frank Caraballo <fecaraballo{at}gmail{dot}com>2010-05-12 23:31:33 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:31:33 +0200
commitf1c03f5b0f3bb4aebbaa4d0a1fdde68e915b565e (patch)
tree88b6a48360ac88835175c92fd23ce41585366e80 /libraries/zsi
parentda0e7952343a5d901c11f506617c6ee972171a32 (diff)
downloadslackbuilds-f1c03f5b0f3bb4aebbaa4d0a1fdde68e915b565e.tar.gz
slackbuilds-f1c03f5b0f3bb4aebbaa4d0a1fdde68e915b565e.tar.xz
libraries/zsi: Added to 12.2 repository
Diffstat (limited to 'libraries/zsi')
-rw-r--r--libraries/zsi/README2
-rw-r--r--libraries/zsi/slack-desc19
-rw-r--r--libraries/zsi/zsi.SlackBuild71
-rw-r--r--libraries/zsi/zsi.info8
4 files changed, 100 insertions, 0 deletions
diff --git a/libraries/zsi/README b/libraries/zsi/README
new file mode 100644
index 0000000000..302e375c8f
--- /dev/null
+++ b/libraries/zsi/README
@@ -0,0 +1,2 @@
+ZSI, the Zolera SOAP Infrastructure, is a Python package that provides
+an implementation of SOAP messaging.
diff --git a/libraries/zsi/slack-desc b/libraries/zsi/slack-desc
new file mode 100644
index 0000000000..a20db7df72
--- /dev/null
+++ b/libraries/zsi/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+zsi: ZSI (Zolera SOAP Infrastructure)
+zsi:
+zsi: ZSI, the Zolera SOAP Infrastructure, is a Python package that provides
+zsi: an implementation of SOAP messaging.
+zsi:
+zsi: Homepage: http://pywebsvcs.sourceforge.net/
+zsi:
+zsi:
+zsi:
+zsi:
+zsi:
diff --git a/libraries/zsi/zsi.SlackBuild b/libraries/zsi/zsi.SlackBuild
new file mode 100644
index 0000000000..0b20289a20
--- /dev/null
+++ b/libraries/zsi/zsi.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for ZSI
+
+# Copyright 2008 Frank Caraballo <fecaraballo{at}gmail{dot}com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=zsi
+VERSION=${VERSION:-2.1a1}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf ZSI-2.1-a1
+tar xvf $CWD/ZSI-2.1-a1.tar.?z* || exit 1
+cd ZSI-2.1-a1 || exit 1
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python setup.py build || exit 1
+python setup.py install --root $PKG || exit 1
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES Copyright PKG-INFO README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/zsi/zsi.info b/libraries/zsi/zsi.info
new file mode 100644
index 0000000000..5f82deef35
--- /dev/null
+++ b/libraries/zsi/zsi.info
@@ -0,0 +1,8 @@
+PRGNAM="zsi"
+VERSION="2.1a1"
+HOMEPAGE="http://pywebsvcs.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/pywebsvcs/ZSI-2.1-a1.tar.gz"
+MD5SUM="a98e15e4d5a60f77714eb188de387c7c"
+MAINTAINER="Frank Caraballo"
+EMAIL="fecaraballo{at}gmail{dot}com"
+APPROVED="dsomero"