summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Heinz Wiesinger <HMWiesinger@gmx.at>2010-05-11 22:24:11 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-11 22:24:11 +0200
commit21f7100979ec4ab5dfcb00703fdf038c5778ddef (patch)
treeba2d9547a80de618ce6374ebf0a1b699997f416b /libraries
parent0e1f8049f04ce05644a23b1452aa1b8fa39f8594 (diff)
downloadslackbuilds-21f7100979ec4ab5dfcb00703fdf038c5778ddef.tar.gz
slackbuilds-21f7100979ec4ab5dfcb00703fdf038c5778ddef.tar.xz
libraries/libzip: Updated for version 0.9
Diffstat (limited to 'libraries')
-rw-r--r--libraries/libzip/libzip.SlackBuild27
-rw-r--r--libraries/libzip/libzip.info8
2 files changed, 22 insertions, 13 deletions
diff --git a/libraries/libzip/libzip.SlackBuild b/libraries/libzip/libzip.SlackBuild
index f877d7bae2..3768d86fd4 100644
--- a/libraries/libzip/libzip.SlackBuild
+++ b/libraries/libzip/libzip.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for libzip
-# Copyright 2007 Heinz Wiesinger <hmwiesinger@gmx.at>
+# Copyright 2007-2008 Heinz Wiesinger <hmwiesinger@gmx.at>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=libzip
-VERSION=0.8
+VERSION=0.9
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -37,6 +37,8 @@ if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
fi
set -e
@@ -45,10 +47,17 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# un-hardlink manpages
+sed -i -e "s/LN \= ln/LN \= ln -s/" man/Makefile.in
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -57,15 +66,15 @@ CXXFLAGS="$SLKCFLAGS" \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
- --disable-static
+ --disable-static \
+ --build=$ARCH-slackware-linux \
+ --host=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
diff --git a/libraries/libzip/libzip.info b/libraries/libzip/libzip.info
index abca5c45e7..62cf5a41ee 100644
--- a/libraries/libzip/libzip.info
+++ b/libraries/libzip/libzip.info
@@ -1,8 +1,8 @@
PRGNAM="libzip"
-VERSION="0.8"
+VERSION="0.9"
HOMEPAGE="http://www.nih.at/libzip/"
-DOWNLOAD="http://www.nih.at/libzip/libzip-0.8.tar.gz"
-MD5SUM="b0087c2a12b312f8ec2df1052b2acb4f"
+DOWNLOAD="http://www.nih.at/libzip/libzip-0.9.tar.bz2"
+MD5SUM="56b9f11c1eee5eed189a20183d7e06b0"
MAINTAINER="ppr:kut"
EMAIL="HMWiesinger@gmx.at"
-APPROVED="rworkman"
+APPROVED="David Somero" \ No newline at end of file