summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2022-02-07 21:01:08 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-09 09:35:18 +0700
commit4706b2b5dc88a08414a0f7670b46dfd3d40a3b06 (patch)
tree0075d9b5a05b6170bba29b2ba4da94c12ec77333 /libraries
parent9051188f378022f72860b5d61b781ecbc1db1677 (diff)
downloadslackbuilds-4706b2b5dc88a08414a0f7670b46dfd3d40a3b06.tar.gz
slackbuilds-4706b2b5dc88a08414a0f7670b46dfd3d40a3b06.tar.xz
libraries/CEGUI: Updated for version 0.8.7.
Added a note about the incompatibility with ogre Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/CEGUI/CEGUI.SlackBuild19
-rw-r--r--libraries/CEGUI/CEGUI.info6
-rw-r--r--libraries/CEGUI/README5
3 files changed, 22 insertions, 8 deletions
diff --git a/libraries/CEGUI/CEGUI.SlackBuild b/libraries/CEGUI/CEGUI.SlackBuild
index ac1e1c5e7c..605546ce5c 100644
--- a/libraries/CEGUI/CEGUI.SlackBuild
+++ b/libraries/CEGUI/CEGUI.SlackBuild
@@ -9,14 +9,14 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=CEGUI
SRCNAM=cegui
-VERSION=${VERSION:-0.8.4}
+VERSION=${VERSION:-0.8.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -34,8 +34,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -63,6 +63,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+sed -i '1iadd_definitions(-std=c++11)' \
+ cegui/src/RendererModules/OpenGL/CMakeLists.txt \
+ cegui/src/RendererModules/Ogre/CMakeLists.txt \
+ application_templates/CMakeLists.txt \
+ samples_framework/CMakeLists.txt
+
mkdir build
cd build
cmake \
@@ -72,6 +78,11 @@ cd build
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
-DMAN_INSTALL_DIR=/usr/man \
+ -DCEGUI_BUILD_XMLPARSER_LIBXML2=OFF \
+ -DCEGUI_BUILD_LUA_MODULE=OFF \
+ -DCEGUI_BUILD_LUA_GENERATOR=OFF \
+ -DCEGUI_BUILD_LUA_GENERATOR=OFF \
+ -DCEGUI_BUILD_XMLPARSER_XERCES=OFF \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
diff --git a/libraries/CEGUI/CEGUI.info b/libraries/CEGUI/CEGUI.info
index 330367be14..1e684af0c2 100644
--- a/libraries/CEGUI/CEGUI.info
+++ b/libraries/CEGUI/CEGUI.info
@@ -1,8 +1,8 @@
PRGNAM="CEGUI"
-VERSION="0.8.4"
+VERSION="0.8.7"
HOMEPAGE="http://cegui.org.uk/wiki/Main_Page"
-DOWNLOAD="http://sourceforge.net/projects/crayzedsgui/files/CEGUI%20Mk-2/0.8/cegui-0.8.4.tar.bz2"
-MD5SUM="344917301b5ed867a07575ee6a828667"
+DOWNLOAD="http://downloads.sf.net/crayzedsgui/cegui-0.8.7.tar.bz2"
+MD5SUM="cebcc95e205b9ad353db0d65b9b2d505"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/libraries/CEGUI/README b/libraries/CEGUI/README
index 7a49259d69..27e98d5916 100644
--- a/libraries/CEGUI/README
+++ b/libraries/CEGUI/README
@@ -15,4 +15,7 @@ to disable the others to ensure that the one you want to use is the
default codec.
Optional dependencies include xerces-c, FreeImage, and DevIL.
-There are perhaps others - see output of "configure --help"
+There are perhaps others - see the CMakeList.txt file
+
+*NOTE* ATM this won't build with ogre installed: you have to remove
+it explicitly from your system.