summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Serban Udrea <S.Udrea@gsi.de>2019-01-18 08:34:35 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-01-18 23:39:53 +0700
commit4ea8df8eb9a3f7cb2fd355231ba3dd74b35540c3 (patch)
tree3ed4f92286b2445b5828742041c224db2c01df8f /libraries
parent4c1847b39a305082d9303799b1baaeb79116b4e1 (diff)
downloadslackbuilds-4ea8df8eb9a3f7cb2fd355231ba3dd74b35540c3.tar.gz
slackbuilds-4ea8df8eb9a3f7cb2fd355231ba3dd74b35540c3.tar.xz
libraries/matplotlib: Fix script.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/matplotlib/README21
-rw-r--r--libraries/matplotlib/matplotlib.SlackBuild17
2 files changed, 27 insertions, 11 deletions
diff --git a/libraries/matplotlib/README b/libraries/matplotlib/README
index b980be8ab2..c7266d9f6d 100644
--- a/libraries/matplotlib/README
+++ b/libraries/matplotlib/README
@@ -4,11 +4,20 @@ development and web application servers targeting multiple user
interfaces and hardcopy output formats. The 'pylab' mode
of ipython uses matplotlib to emulate matlab graphics.
-OPTIONAL DEPENDENCIES: pytest, mock, ffmpeg/avconv, Inkscape
+OPTIONAL DEPENDENCIES: pytest, mock, ffmpeg/avconv, Inkscape,
+ wxPython3
-NOTES: If you want to enable the optional subpackages tests and
+NOTES: The optional wxagg backend is disabled by default because
+ of possible issues related to wxPython versions. If you
+ wish to use this backend install wxPython3 in advance and
+ set DISABLE_WXAGG to "no" when executing the SlackBuild.
+ IMPORTANT: There is some interaction between wxPython and
+ wxPython3, pay attention to the corresponding
+ README files.
+
+ If you want to enable the optional subpackages tests and
toolkits_tests you need to set the variable ENABLE_TESTS
- to "yes" and make sure that pytest, mock, ffmpeg/avconv
- and Inkscape are already installed. Besides ffmpeg/avconv
- are also needed if you wish better support of animation
- output formats.
+ to "yes" when executing the SlackBuild and make sure that
+ pytest, mock, ffmpeg/avconv and Inkscape are already
+ installed. Besides ffmpeg/avconv are also needed if you
+ wish better support of animation output formats.
diff --git a/libraries/matplotlib/matplotlib.SlackBuild b/libraries/matplotlib/matplotlib.SlackBuild
index ffb54ac043..d73281a6c1 100644
--- a/libraries/matplotlib/matplotlib.SlackBuild
+++ b/libraries/matplotlib/matplotlib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for matplotlib
-# Copyright 2011-2018 Serban Udrea <s.udrea@gsi.de>
+# Copyright 2011-2019 Serban Udrea <s.udrea@gsi.de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification,
@@ -30,11 +30,12 @@
PRGNAM=matplotlib
VERSION=${VERSION:-2.2.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
-TARBALL_VERSION=${TARBALL_VERSION:-2.2.3} # Tarball sometimes has a wrong version number
+TARBALL_VERSION=${TARBALL_VERSION:-2.2.3} # Tarball may have wrong versioning
ENABLE_TESTS=${ENABLE_TESTS:-N}
+DISABLE_WXAGG=${DISABLE_WXAGG:-Y}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -65,19 +66,25 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
ENABLE_TESTS=$(echo "$ENABLE_TESTS"|cut -b 1|tr a-z A-Z)
+DISABLE_WXAGG=$(echo "$DISABLE_WXAGG"|cut -b 1|tr a-z A-Z)
+cat setup.cfg.template > setup.cfg
if [ "$ENABLE_TESTS" = "Y" ]
then
- cat setup.cfg.template > setup.cfg
sed -i "s|#tests = False|tests = True|" setup.cfg
fi
+if [ "$DISABLE_WXAGG" = "Y" ]
+then
+ sed -i "s|#wxagg = auto|wxagg = False|" setup.cfg
+fi
+
# Use modified setupext.py to make sure that the build process gets
# interrupted if requirements are not fulfilled
#
cat "${CWD}/setupext.py" > setupext.py
-python setup.py install --root $PKG > ${CWD}/SETUP.OUTPUT 2>&1
+python setup.py install --root $PKG # > ${CWD}/SETUP.OUTPUT 2>&1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true