summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2022-02-06 17:02:32 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-07 00:08:51 +0700
commit92f2897b7db5651e917779a079753a2a8aff9d50 (patch)
treec7bfe01a0c2796cc21c4d89dad2ac53eb17110c9 /libraries
parent329b6fc448ecfabe756c5fa93e0e4acea37a6a6c (diff)
downloadslackbuilds-92f2897b7db5651e917779a079753a2a8aff9d50.tar.gz
slackbuilds-92f2897b7db5651e917779a079753a2a8aff9d50.tar.xz
libraries/libtorrent-rasterbar-legacy: Removed.
This is incompatible with the newer boost Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/libtorrent-rasterbar-legacy/README16
-rw-r--r--libraries/libtorrent-rasterbar-legacy/README.SBo9
-rw-r--r--libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.SlackBuild129
-rw-r--r--libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.info10
-rw-r--r--libraries/libtorrent-rasterbar-legacy/slack-desc19
5 files changed, 0 insertions, 183 deletions
diff --git a/libraries/libtorrent-rasterbar-legacy/README b/libraries/libtorrent-rasterbar-legacy/README
deleted file mode 100644
index c16982719f..0000000000
--- a/libraries/libtorrent-rasterbar-legacy/README
+++ /dev/null
@@ -1,16 +0,0 @@
-libtorrent-rasterbar is a C++ library that aims to be a good alternative
-to all the other bittorrent implementations around. It is a library and
-not a full featured client, although it comes with a working example
-client.
-
-*When upgrading, please removepkg the old version first or the python
-module will try to link against it*
-
-OPTIONS
-
- To build examples and copy them to /usr/doc/...:
-
- EXAMPLES=yes ./libtorrent-rasterbar-legacy.SlackBuild
-
-It is possible to build with bindings for python3 rather than python2 by
-setting the $PYTHON environmental variable
diff --git a/libraries/libtorrent-rasterbar-legacy/README.SBo b/libraries/libtorrent-rasterbar-legacy/README.SBo
deleted file mode 100644
index 739d87d23b..0000000000
--- a/libraries/libtorrent-rasterbar-legacy/README.SBo
+++ /dev/null
@@ -1,9 +0,0 @@
-libtorrent-rasterbar 1.1.* (packaged here as libtorrent-rasterbar-
-legacy) is ABI incompatible with libtorrent-rasterbar-1.2.*. It is made
-available here because it is a build and run time dependency for
-qBittorrent.
-
-In summary: If you would like to install an older version of qBittorrent
-or tribler built with qt4, install this package. If you would like to
-install qbittorrent-qt5, then do not install this package. Instead,
-install libtorrent-rasterbar.
diff --git a/libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.SlackBuild b/libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.SlackBuild
deleted file mode 100644
index b2f1dff5ce..0000000000
--- a/libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.SlackBuild
+++ /dev/null
@@ -1,129 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for libtorrent (rasterbar)
-
-# Copyright 2019-2020 Donald Cooley, South Haven, Indiana USA
-# Copyright 2009-2015 Erik W. Hanson, Minneapolis, MN, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=libtorrent-rasterbar-legacy
-SRCNAM=libtorrent-rasterbar
-VERSION=${VERSION:-1.1.14}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) export ARCH=i586 ;;
- arm*) export ARCH=arm ;;
- *) export ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# https://github.com/qbittorrent/qBittorrent/issues/6383#issuecomment-281535787
-sed -i -e "s/+ target_specific(),/+ target_specific() + ['-std=c++11'],/" \
- bindings/python/setup.py
-
-EXAMPLES=${EXAMPLES:-no}
-[ "$EXAMPLES" = "yes" ] && examples="--enable-examples"
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS -std=c++11" \
-LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --disable-static \
- --enable-python-binding \
- --enable-encryption \
- $examples \
- --with-boost-libdir=/usr/lib${LIBDIRSUFFIX} \
- --disable-debug \
- --build=$ARCH-slackware-linux
-
-make
-make install-strip DESTDIR=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog NEWS docs/ tools/ \
- $PKG/usr/doc/$PRGNAM-$VERSION
-
-if [ "$EXAMPLES" = "yes" ]; then
- cp -a examples/ $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a ed25519/ $PKG/usr/doc/$PRGNAM-$VERSION
-fi
-
-find $PKG \
- \( -name .deps -o -name .libs -o -name .dirstamp \
- \) -exec rm -rf {} \; || true
-
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.info b/libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.info
deleted file mode 100644
index 62fc8caab7..0000000000
--- a/libraries/libtorrent-rasterbar-legacy/libtorrent-rasterbar-legacy.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="libtorrent-rasterbar-legacy"
-VERSION="1.1.14"
-HOMEPAGE="https://libtorrent.org/"
-DOWNLOAD="https://github.com/arvidn/libtorrent/releases/download/libtorrent-1_1_14/libtorrent-rasterbar-1.1.14.tar.gz"
-MD5SUM="2955bfc076bad6dfacc62bdd7d9a4cdb"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Donald Cooley"
-EMAIL="chytraeu@sdf.org"
diff --git a/libraries/libtorrent-rasterbar-legacy/slack-desc b/libraries/libtorrent-rasterbar-legacy/slack-desc
deleted file mode 100644
index 30eb117aa2..0000000000
--- a/libraries/libtorrent-rasterbar-legacy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-libtorrent-rasterbar-legacy: libtorrent-rasterbar-legacy (a bittorrent C++ library)
-libtorrent-rasterbar-legacy:
-libtorrent-rasterbar-legacy: libtorrent is a C++ library that aims to be a good alternative to all
-libtorrent-rasterbar-legacy: of the other bittorrent implementations around. It is a library, not
-libtorrent-rasterbar-legacy: a full featured client, although it comes with an example client.
-libtorrent-rasterbar-legacy:
-libtorrent-rasterbar-legacy: Homepage: https://libtorrent.org/
-libtorrent-rasterbar-legacy:
-libtorrent-rasterbar-legacy:
-libtorrent-rasterbar-legacy:
-libtorrent-rasterbar-legacy: