summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2022-02-06 11:48:23 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-07 00:08:51 +0700
commite2d1dbaf7a6dd419555f0ca6d882d30938cb0530 (patch)
treee6f53349e9d104245242db879b08d9f8d7087c42 /libraries
parenta3a0616993309f9d83c038bbde49c6e71bd93fec (diff)
downloadslackbuilds-e2d1dbaf7a6dd419555f0ca6d882d30938cb0530.tar.gz
slackbuilds-e2d1dbaf7a6dd419555f0ca6d882d30938cb0530.tar.xz
libraries/mariadb_client: Removed (substituted by connector, FTB).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/mariadb_client/README9
-rw-r--r--libraries/mariadb_client/mariadb_client.SlackBuild115
-rw-r--r--libraries/mariadb_client/mariadb_client.info10
-rw-r--r--libraries/mariadb_client/slack-desc19
4 files changed, 0 insertions, 153 deletions
diff --git a/libraries/mariadb_client/README b/libraries/mariadb_client/README
deleted file mode 100644
index 4ad1696bbe..0000000000
--- a/libraries/mariadb_client/README
+++ /dev/null
@@ -1,9 +0,0 @@
-The MariaDB Client Library for C is used to connect
-applications developed in C/C++ to MariaDB and MySQL
-databases.The client library is LGPL licensed.
-
-The MariaDB Client Library for C has exactly the same
-API as the MySQL Connector/C for MySQL 5.5
-
-To build HTML documentation build with BUILD_DOCS=yes.
-
diff --git a/libraries/mariadb_client/mariadb_client.SlackBuild b/libraries/mariadb_client/mariadb_client.SlackBuild
deleted file mode 100644
index 226a49c23d..0000000000
--- a/libraries/mariadb_client/mariadb_client.SlackBuild
+++ /dev/null
@@ -1,115 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for mariadb_client
-
-# Copyright 2014 Robert Allen
-# All rights reserved, including Creator Endowed Unalienable Rights
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=mariadb_client
-VERSION=${VERSION:-2.0.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-BUILD_DOCS=${BUILD_DOCS:-no}
-SVERSION=$VERSION"-src"
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$SVERSION
-tar xvf $CWD/$PRGNAM-$SVERSION.tar.gz
-cd $PRGNAM-$SVERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-sed -i "s|lib/mariadb|lib${LIBDIRSUFFIX}/mariadb|" libmariadb/CMakeLists.txt
-
-#Note: The distribution makefile fails when building docs out of tree.
-#I am not familiar enough with cmake to sort it out, so we build in tree.
- cmake \
- -DBUILD_DOCS:STRING="$BUILD_DOCS" \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DPLUGINDIR=/usr/lib${LIBDIRSUFFIX}/plugin \
- -DCMAKE_BUILD_TYPE=Release .
-
- make
- make install DESTDIR=$PKG
-
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README COPYING.LIB $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-if [ "$BUILD_DOCS" != 'no' ]; then
- cp -r docs/html/ $PKG/usr/doc/$PRGNAM-$VERSION/.
-fi
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/mariadb_client/mariadb_client.info b/libraries/mariadb_client/mariadb_client.info
deleted file mode 100644
index 03c0413f60..0000000000
--- a/libraries/mariadb_client/mariadb_client.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="mariadb_client"
-VERSION="2.0.0"
-HOMEPAGE="https://mariadb.com/kb/en/mariadb/client-libraries/client-library-for-c/"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/mariadb_client-2.0.0-src.tar.gz"
-MD5SUM="a233181e03d3c307668b4c722d881661"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Robert Allen"
-EMAIL="slacker@engineer.com"
diff --git a/libraries/mariadb_client/slack-desc b/libraries/mariadb_client/slack-desc
deleted file mode 100644
index 9d48da03a0..0000000000
--- a/libraries/mariadb_client/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-mariadb_client: mariadb_client (Native C/C++ API for MariaDB and MySQL)
-mariadb_client:
-mariadb_client: This is LGPL MariaDB client library that can be used to connect to
-mariadb_client: MySQL or MariaDB.
-mariadb_client:
-mariadb_client:
-mariadb_client:
-mariadb_client:
-mariadb_client:
-mariadb_client:
-mariadb_client: