summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2018-09-04 05:10:53 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-09-08 08:37:47 +0700
commitae47f4f2b1e11c35bf01df0b787888f03f6a3a53 (patch)
treee261a5e825982fc6e85574af0a1f839929329048 /multimedia
parent80528372e9391419d046033f8460b8c4419d333e (diff)
downloadslackbuilds-ae47f4f2b1e11c35bf01df0b787888f03f6a3a53.tar.gz
slackbuilds-ae47f4f2b1e11c35bf01df0b787888f03f6a3a53.tar.xz
multimedia/glyr: Apply upstream fix for lyricswiki.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/glyr/glyr.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/multimedia/glyr/glyr.SlackBuild b/multimedia/glyr/glyr.SlackBuild
index 5faed92684..aad64c7006 100644
--- a/multimedia/glyr/glyr.SlackBuild
+++ b/multimedia/glyr/glyr.SlackBuild
@@ -24,6 +24,7 @@
# Now maintained by B. Watson <yalhcru@gmail.com>
+# 20180904 bkw: BUILD=2, fix lyricswiki
# 20170302 bkw: use long-format github URL
# 20170121 bkw:
@@ -39,7 +40,7 @@
PRGNAM=glyr
VERSION=${VERSION:-1.0.10}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -80,12 +81,11 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# 20180904 bkw: fix from upstream git, for the lyricswiki provider.
+patch -p1 < $CWD/94967c3.diff
# upstream places -Os after the flags we provide, which undoes our -O2.
sed -i "s,-Os,," CMakeLists.txt