summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-02-16 15:03:25 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-19 12:09:21 +0700
commitc8383864fad240a8c8d37db9fa7973c0f0737d80 (patch)
tree69d29d451534efb8c03e10cd28b7ed325ae6ceb0 /multimedia
parent2ba075f31b89147ee7f46d930834b14aebf0ee5d (diff)
downloadslackbuilds-c8383864fad240a8c8d37db9fa7973c0f0737d80.tar.gz
slackbuilds-c8383864fad240a8c8d37db9fa7973c0f0737d80.tar.xz
multimedia/tvheadend: Fix build (network access).
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/tvheadend/libhdhomerun.diff16
-rw-r--r--multimedia/tvheadend/tvheadend.SlackBuild27
-rw-r--r--multimedia/tvheadend/tvheadend.info8
3 files changed, 41 insertions, 10 deletions
diff --git a/multimedia/tvheadend/libhdhomerun.diff b/multimedia/tvheadend/libhdhomerun.diff
new file mode 100644
index 0000000000..e3551769cf
--- /dev/null
+++ b/multimedia/tvheadend/libhdhomerun.diff
@@ -0,0 +1,16 @@
+diff -Naur tvheadend-4.2.8/Makefile.hdhomerun tvheadend-4.2.8.patched/Makefile.hdhomerun
+--- tvheadend-4.2.8/Makefile.hdhomerun 2019-01-12 03:58:47.000000000 -0500
++++ tvheadend-4.2.8.patched/Makefile.hdhomerun 2022-02-16 13:55:18.391084069 -0500
+@@ -32,10 +32,10 @@
+ # Upstream Packages
+ # ###########################################################################
+
+-LIBHDHR = libhdhomerun_20171221
++LIBHDHR = libhdhomerun_20210624
+ LIBHDHR_TB = $(LIBHDHR).tgz
+ LIBHDHR_URL = http://download.silicondust.com/hdhomerun/$(LIBHDHR_TB)
+-LIBHDHR_SHA1 = 6b019728eadea3af7a5686ed5ba44e970bca7365
++LIBHDHR_SHA1 = 9db6089b956de4e58084b623937f5fc3231fff0b
+
+ # ###########################################################################
+ # Library Config
diff --git a/multimedia/tvheadend/tvheadend.SlackBuild b/multimedia/tvheadend/tvheadend.SlackBuild
index 0823783175..e117895e2e 100644
--- a/multimedia/tvheadend/tvheadend.SlackBuild
+++ b/multimedia/tvheadend/tvheadend.SlackBuild
@@ -22,6 +22,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220216 bkw: Modified by SlackBuilds.org:
+# - stop trying to download files from the SlackBuild. our scripts must
+# run without network access.
+# - fix build for latest libhdhomerun.
+# - disable pcloud, since it fails even if we let the Makefile download it.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tvheadend
@@ -38,9 +44,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -66,23 +69,30 @@ fi
set -e
+DATAVER=${DATAVER:-$VERSION}
+HDHRVER=${HDHRVER:-20210624}
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION-data-dvb-scan.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
patch -p1 < $CWD/tvheadend-4.2.8-gcc9.patch
patch -p1 < $CWD/tvheadend-4.2.8-fno-common.patch
-CFLAGS="$SLKCFLAGS -Wno-error=stringop-truncation -Wno-error=attributes" \
+# 20220216 bkw: use latest libhdhomerun
+patch -p1 < $CWD/libhdhomerun.diff
+
+CFLAGS="$SLKCFLAGS -Wno-error -DHDHOMERUN_TAG_DEVICE_AUTH_BIN=HDHOMERUN_TAG_DEVICE_AUTH_BIN_DEPRECATED" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
@@ -97,9 +107,10 @@ CXXFLAGS="$SLKCFLAGS" \
--disable-libvorbis_static \
--disable-libfdkaac_static \
--python=python3 \
+ --disable-pcloud_cache \
--build=$ARCH-slackware-linux
-make
+make V=1 TVHEADEND_FILE_CACHE=$CWD
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/multimedia/tvheadend/tvheadend.info b/multimedia/tvheadend/tvheadend.info
index 176900fb09..03cc3310a4 100644
--- a/multimedia/tvheadend/tvheadend.info
+++ b/multimedia/tvheadend/tvheadend.info
@@ -1,8 +1,12 @@
PRGNAM="tvheadend"
VERSION="4.2.8"
HOMEPAGE="https://tvheadend.org"
-DOWNLOAD="https://github.com/tvheadend/tvheadend/archive/v4.2.8/tvheadend-4.2.8.tar.gz"
-MD5SUM="b9571efa46dd489f9fe87acdb391d591"
+DOWNLOAD="https://github.com/tvheadend/tvheadend/archive/v4.2.8/tvheadend-4.2.8.tar.gz \
+ https://slackware.uk/~urchlay/src/tvheadend-4.2.8-data-dvb-scan.tar.xz \
+ https://download.silicondust.com/hdhomerun/libhdhomerun_20210624.tgz"
+MD5SUM="b9571efa46dd489f9fe87acdb391d591 \
+ cc49260170f458000c944eac54bf213d \
+ 233844b9238bd42cfdfbbd126a088fd2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="uriparser"