summaryrefslogtreecommitdiffstats
path: root/network/CherryMusic
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-05-27 07:29:34 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-06-10 09:22:59 +0700
commit3c32faa409e03319273f1dd8d40f1509f943d1cb (patch)
tree4e5a54a60f794db27b45839c1cd6291545a7ac30 /network/CherryMusic
parent4e3eae3ab67eff7a27e4efdeb2bda9a632b63da9 (diff)
downloadslackbuilds-3c32faa409e03319273f1dd8d40f1509f943d1cb.tar.gz
slackbuilds-3c32faa409e03319273f1dd8d40f1509f943d1cb.tar.xz
network/CherryMusic: Removed: (replaced by python3-CherryMusic)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/CherryMusic')
-rw-r--r--network/CherryMusic/CherryMusic.SlackBuild103
-rw-r--r--network/CherryMusic/CherryMusic.info10
-rw-r--r--network/CherryMusic/README16
-rw-r--r--network/CherryMusic/doinst.sh3
-rw-r--r--network/CherryMusic/slack-desc19
5 files changed, 0 insertions, 151 deletions
diff --git a/network/CherryMusic/CherryMusic.SlackBuild b/network/CherryMusic/CherryMusic.SlackBuild
deleted file mode 100644
index 680c8c7530..0000000000
--- a/network/CherryMusic/CherryMusic.SlackBuild
+++ /dev/null
@@ -1,103 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for CherryMusic
-
-# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=CherryMusic
-VERSION=${VERSION:-0.40.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-install -D -m644 doc/man/cherrymusic.1 $PKG/usr/man/man1/cherrymusic.1
-install -D -m644 doc/man/cherrymusic.conf.5 $PKG/usr/man/man5/cherrymusic.conf.5
-install -D -m644 doc/man/cherrymusicd.8 $PKG/usr/man/man8/cherrymusicd.8
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/CherryMusic/CherryMusic.info b/network/CherryMusic/CherryMusic.info
deleted file mode 100644
index 7ee7e2722e..0000000000
--- a/network/CherryMusic/CherryMusic.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="CherryMusic"
-VERSION="0.40.0"
-HOMEPAGE="http://www.fomori.org/cherrymusic/"
-DOWNLOAD="https://pypi.python.org/packages/bd/af/118542a136d18a7389b142fc0a1b38842d86af1c938998a9e11de8b73afc/CherryMusic-0.40.0.tar.gz"
-MD5SUM="4e771c2e5a3da2500296893428bfc27c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="CherryPy"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/network/CherryMusic/README b/network/CherryMusic/README
deleted file mode 100644
index 3ec1d3c6e7..0000000000
--- a/network/CherryMusic/README
+++ /dev/null
@@ -1,16 +0,0 @@
-CherryMusic is a music streaming server based on CherryPy and jPlayer.
-It can be run remotely or on a single computer and is designed to
-handle huge music libraries of 3 TB and more; it also works well
-with small collections. In contrast to MPD, Icecast and the like,
-CherryMusic allows multiple users to log in via HTTP/HTTPS using a web
-browser, browse and search the music database, manage playlists and
-stream music to the browser.
-
-The CherryMusic server runs on Linux, Windows and OS X, as long as
-Python and SQLite are available. To use the web client, any device
-with a modern browser will do.
-
-Optional dependencies are:
-
- Live transcoding: faad2
- For special character search terms: python-unidecode
diff --git a/network/CherryMusic/doinst.sh b/network/CherryMusic/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/network/CherryMusic/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/network/CherryMusic/slack-desc b/network/CherryMusic/slack-desc
deleted file mode 100644
index 17410f4f20..0000000000
--- a/network/CherryMusic/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-CherryMusic: CherryMusic (music streaming server)
-CherryMusic:
-CherryMusic: CherryMusic is a music streaming server based on CherryPy and
-CherryMusic: jPlayer. It can be run remotely or on a single computer and is
-CherryMusic: designed to handle huge music libraries of 3 TB and more; it also
-CherryMusic: works well with small collections. In contrast to MPD, Icecast
-CherryMusic: and the like, CherryMusic allows multiple users to log in via
-CherryMusic: HTTP/HTTPS using a web browser, browse and search the music
-CherryMusic: database, manage playlists and stream music to the browser.
-CherryMusic:
-CherryMusic: Homepage: http://www.fomori.org/cherrymusic/