summaryrefslogtreecommitdiffstats
path: root/network/basilisk-src
diff options
context:
space:
mode:
author khronosschoty <khronosschoty@posteo.org>2018-05-02 11:53:48 +0100
committer David Spencer <idlemoor@slackbuilds.org>2018-05-02 11:53:48 +0100
commit7488e2780fd9bb7b58d49cf7af71d334d7d092df (patch)
tree8f243e8671af5a6cf18a5a8c840acb27848e5af4 /network/basilisk-src
parentd7f80e2c4753d08edc14c3219a2c04608c271371 (diff)
downloadslackbuilds-7488e2780fd9bb7b58d49cf7af71d334d7d092df.tar.gz
slackbuilds-7488e2780fd9bb7b58d49cf7af71d334d7d092df.tar.xz
network/basilisk-src: Updated for version 2018.04.23.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'network/basilisk-src')
-rw-r--r--network/basilisk-src/README23
-rw-r--r--network/basilisk-src/basilisk-src.SlackBuild37
-rw-r--r--network/basilisk-src/basilisk-src.info6
-rw-r--r--network/basilisk-src/slack-desc12
4 files changed, 49 insertions, 29 deletions
diff --git a/network/basilisk-src/README b/network/basilisk-src/README
index 11de88ef77..f6dacb48d7 100644
--- a/network/basilisk-src/README
+++ b/network/basilisk-src/README
@@ -1,7 +1,20 @@
-Basilisk browser demonstration program for the Unified XUL Platform.
+Basilisk (Web browser -- BUILD FROM SOURCE)
-The Unified XUL Platform (UXP) -- Codename Möbius, is a hard fork from the
-Mozilla code repository (mozilla-central) with an early 2017 fork point.
+Note: this builds Basilisk from source and conflicts with the binary
+repackage also found on SBo.
-This builds Basilisk from source and conflicts with the binary repackage also
-found on SBo.
+Basilisk is a demonstration program for the Unified XUL Platform (XUP).
+It is a hard fork from the Mozilla code repository (mozilla-central)
+with an ESR-52 fork point.
+
+Some build time options:
+
+ GTK=gtk2 ./basilisk-src.SlackBuild
+
+will override the default and build with gtk2 instead of gtk3.
+
+jack-audio-connection-kit is an optional dependency and, if detected,
+automatically built. If this is undesirable you can blacklist jack, by
+passing the variable:
+
+ BLACKLIST_JACK=yes ./basilisk-src.SlackBuild
diff --git a/network/basilisk-src/basilisk-src.SlackBuild b/network/basilisk-src/basilisk-src.SlackBuild
index 75721cc7e7..e2b20b9731 100644
--- a/network/basilisk-src/basilisk-src.SlackBuild
+++ b/network/basilisk-src/basilisk-src.SlackBuild
@@ -25,9 +25,9 @@
# Modified by SlackBuilds.org
PRGNAM=basilisk-src
-VERSION=${VERSION:-2018.02.11}
+VERSION=${VERSION:-2018.04.23}
BUILD=${BUILD:-1}
-TAG=${TAG:-SBo}
+TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -42,6 +42,10 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+OBJ=${OBJ:-obj-$PRGNAM}
+GTK=${GTK:-gtk3}
+EME=${EME:---enable-eme=widevine}
+
# You can try changing the optimization level to simply "-O2" if your processor
# doesn't support sse2 instructions.
# "-Os" might help if you experience segfaults.
@@ -63,14 +67,14 @@ fi
# The default is to build with official branding. This SlackBuild is used to
# produce officially approved third party "contributed builds" of Basilisk.
# This SlackBuild can also be used to produce unapproved packages -- which
-# requires the use of the "unofficial"
+# requires the use of the "unofficial" branding.
BRANDING=${BRANDING:---enable-official-branding}
if [ "$BRANDING" = "unofficial" ]; then
BRANDING="--disable-official-branding --with-branding=browser/branding/unofficial"
fi
-rm -rf $PKG $TMP/gold $TMP/obj
-mkdir -p $TMP $PKG $OUTPUT $TMP/gold $TMP/obj
+rm -rf $PKG $TMP/gold $TMP/$OBJ
+mkdir -p $TMP $PKG $OUTPUT $TMP/gold $TMP/$OBJ
DEBUG=" --enable-strip --disable-debug --disable-debug-symbols --enable-release"
if [ "${ENABLE_DEBUG:-no}" = "yes" ]; then
@@ -127,9 +131,9 @@ PATH=$TMP/autoconf-tmp/usr/bin:$PATH
# Build basilisk
cd $TMP
-rm -rf moebius-$VERSION
-tar -xvf $CWD/moebius-$VERSION.tar.gz
-cd moebius-$VERSION
+rm -rf UXP-$VERSION
+tar -xvf $CWD/UXP-$VERSION.tar.gz
+cd UXP-$VERSION
chown -R root:root .
find -L . \
@@ -142,7 +146,7 @@ find -L . \
# "UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 36: ordinal not in range(128)"
export LANG=C
-export MOZCONFIG="$TMP/moebius-$VERSION/.mozconfig"
+export MOZCONFIG="$TMP/UXP-$VERSION/.mozconfig"
export MOZILLA_OFFICIAL=1
export MOZ_MAKE_FLAGS=$MAKEFLAGS
export CFLAGS="$SLKCFLAGS"
@@ -161,18 +165,18 @@ OPTIONS="\
--libdir=/usr/lib${LIBDIRSUFFIX} \
--with-default-mozilla-five-home=/usr/lib${LIBDIRSUFFIX}/$PRGNAM-$VERSION \
--x-libraries=/usr/lib${LIBDIRSUFFIX} \
- --enable-default-toolkit=cairo-gtk3 \
+ --enable-default-toolkit=cairo-$GTK \
$DEBUG \
$DEVTOOLS \
+ $EME \
--enable-application=browser \
--disable-crashreporter \
--disable-updater \
--disable-tests \
- --enable-eme=widevine \
--enable-jemalloc \
--with-pthreads"
-echo "mk_add_options MOZ_OBJDIR=$TMP/obj" > .mozconfig
+echo "mk_add_options MOZ_OBJDIR=$TMP/$OBJ" > .mozconfig
# Write in the .mozconfig the options above
for option in $OPTIONS; do echo "ac_add_options $option" >> .mozconfig; done
@@ -181,11 +185,14 @@ echo "ac_add_options --enable-optimize=\"$OPTIMIZE\"" >> .mozconfig
if ! pkg-config --exists libpulse; then
echo "ac_add_options --disable-pulseaudio" >> .mozconfig; fi
-python2 mach build
+if pkg-config --exists jack && [ "${BLACKLIST_JACK:-no}" != "yes" ]; then
+echo "ac_add_options --enable-jack" >> .mozconfig; fi
+
+make -f client.mk build
## Clean up; and package basilisk.
mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/mozilla/plugins
-cd $TMP/obj
+cd $TMP/$OBJ
make install DESTDIR=$PKG
cd $PKG
@@ -221,11 +228,11 @@ sed "s|@VERSION@|$VERSION|" $CWD/$PRGNAM.desktop \
> $PKG/usr/share/applications/$PRGNAM.desktop
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $TMP/UXP-$VERSION/LEGAL $TMP/UXP-$VERSION/LICENSE $TMP/UXP-$VERSION/README.md $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
-cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/basilisk-src/basilisk-src.info b/network/basilisk-src/basilisk-src.info
index 26227ce497..6231feabad 100644
--- a/network/basilisk-src/basilisk-src.info
+++ b/network/basilisk-src/basilisk-src.info
@@ -1,9 +1,9 @@
PRGNAM="basilisk-src"
-VERSION="2018.02.11"
+VERSION="2018.04.23"
HOMEPAGE="https://github.com/MoonchildProductions/moebius"
-DOWNLOAD="http://repo.khronosschoty.org/Slackware/stuff/basilisk-src/moebius-2018.02.11.tar.gz \
+DOWNLOAD="https://github.com/MoonchildProductions/UXP/archive/v2018.04.23/UXP-2018.04.23.tar.gz \
http://ponce.cc/slackware/sources/repo/autoconf-2.13.tar.xz"
-MD5SUM="1c0642779b1a11175cfb08264edb75b2 \
+MD5SUM="1836973fd4302b0b1c448a5f9ba383b8 \
f2994d302cf736e7e71974edfa51da3c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
diff --git a/network/basilisk-src/slack-desc b/network/basilisk-src/slack-desc
index 7c70649503..8d93c6e5f4 100644
--- a/network/basilisk-src/slack-desc
+++ b/network/basilisk-src/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-basilisk-src: basilisk-src (browser)
+basilisk-src: basilisk-src (Web browser -- BUILD FROM SOURCE)
basilisk-src:
-basilisk-src: Basilisk browser demonstration program for the Unified XUL Platform.
+basilisk-src: Basilisk is a demonstration program for the Unified XUL Platform
+basilisk-src: (XUP). It is a hard fork from the Mozilla code repository
+basilisk-src: (mozilla-central) with an ESR-52 fork point.
basilisk-src:
-basilisk-src: The Unified XUL Platform (UXP) -- Codename Möbius, is a hard fork
-basilisk-src: from the Mozilla code repository (mozilla-central) with an early
-basilisk-src: 2017 fork point.
basilisk-src:
-basilisk-src: https://github.com/MoonchildProductions/moebius
+basilisk-src:
+basilisk-src: https://github.com/MoonchildProductions/UXP
basilisk-src:
basilisk-src: