summaryrefslogtreecommitdiffstats
path: root/network/gmapcatcher/gmapcatcher.SlackBuild
diff options
context:
space:
mode:
author Pablo Santamaria <pablosantamaria@gmail.com>2014-02-09 08:57:31 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-02-11 12:15:06 -0600
commit1be35e49fd8adc9585df13d5e4fa69eda6d17c68 (patch)
treea2efa74505510bad0013d49db2710dda4a0c1422 /network/gmapcatcher/gmapcatcher.SlackBuild
parent68feb96a400a0fd5bbf05f6e41713822694bb2af (diff)
downloadslackbuilds-1be35e49fd8adc9585df13d5e4fa69eda6d17c68.tar.gz
slackbuilds-1be35e49fd8adc9585df13d5e4fa69eda6d17c68.tar.xz
network/gmapcatcher: Updated for version 0.8.0.4.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/gmapcatcher/gmapcatcher.SlackBuild')
-rw-r--r--network/gmapcatcher/gmapcatcher.SlackBuild23
1 files changed, 6 insertions, 17 deletions
diff --git a/network/gmapcatcher/gmapcatcher.SlackBuild b/network/gmapcatcher/gmapcatcher.SlackBuild
index 3f440c13d5..6f2c36ac36 100644
--- a/network/gmapcatcher/gmapcatcher.SlackBuild
+++ b/network/gmapcatcher/gmapcatcher.SlackBuild
@@ -5,8 +5,8 @@
# Written by Pablo Santamaria (pablosantamaria)
PRGNAM=gmapcatcher
-VERSION=${VERSION:-0.7.7.2}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-0.8.0.4}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -41,9 +41,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf GMapCatcher-$VERSION
-tar xvf $CWD/GMapCatcher-$VERSION.tar.gz
-cd GMapCatcher-$VERSION
+rm -rf mapcatcher-$VERSION
+tar xvf $CWD/mapcatcher_${VERSION}.tar.gz
+cd mapcatcher-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -51,19 +51,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Patch setup.py for include tilesRepo
-patch -p1 < $CWD/patch-setup.diff
-
-# Prepare files for install
-rm -rf WindowsMobile
-mv maps.py mapcatcher
-mv download.py mapdownloader
-gzip -9 man/mapcatcher.1
-gzip -9 man/mapdownloader.1
-cp images/map.png images/mapcatcher.png
-chmod a-x gmapcatcher.desktop
-
python setup.py install --root=$PKG
+chmod 644 $PKG/usr/share/applications/gmapcatcher.desktop
( cd $PKG/usr/bin ; ln -s mapcatcher gmapcatcher )
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \