summaryrefslogtreecommitdiffstats
path: root/network/offlineimap/offlineimap.SlackBuild
diff options
context:
space:
mode:
author Nishant Limbachia <nishant@mnspace.net>2011-12-17 10:38:15 -0600
committer Niels Horn <niels.horn@slackbuilds.org>2011-12-18 00:05:10 -0200
commita60ade573538c1b09098283ce1055f2fa72034f7 (patch)
treeb83b830605234d243560466ba3c993f235659b83 /network/offlineimap/offlineimap.SlackBuild
parent534b7b8c7197c432f8f49a2739f4a523ab11f908 (diff)
downloadslackbuilds-a60ade573538c1b09098283ce1055f2fa72034f7.tar.gz
slackbuilds-a60ade573538c1b09098283ce1055f2fa72034f7.tar.xz
network/offlineimap: Updated for version 6.4.0
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'network/offlineimap/offlineimap.SlackBuild')
-rw-r--r--network/offlineimap/offlineimap.SlackBuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/network/offlineimap/offlineimap.SlackBuild b/network/offlineimap/offlineimap.SlackBuild
index e018b31e64..7acacb47f9 100644
--- a/network/offlineimap/offlineimap.SlackBuild
+++ b/network/offlineimap/offlineimap.SlackBuild
@@ -3,7 +3,8 @@
# Slackware build script for OfflineIMAP
# Home Page https://github.com/nicolas33/offlineimap
-# Copyright (c) 2008-2011, Nishant Limbachia, Hoffman Estates, IL, USA <nishant _AT_ mnspace _DOT_ net>
+# Copyright (c) 2008-2011, Nishant Limbachia, Hoffman Estates, IL, USA
+# <nishant _AT_ mnspace _DOT_ net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,9 +25,9 @@
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-SRCNAM="nicolas33-offlineimap-v6.3.4-0-g61e50b3"
+SRCNAM="nicolas33-offlineimap-v6.4.0-0-gc1120c9"
PRGNAM="offlineimap"
-VERSION=${VERSION:-6.3.4}
+VERSION=${VERSION:-6.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -45,11 +46,14 @@ OUTPUT=${OUTPUT:-/tmp}
set -e # Exit on most errors
+# In case the source was fetched with wget or some other downloader:
+[ -e v${VERSION} ] && mv v${VERSION} $SRCNAM.tar.gz
+
rm -fr $TMP/$PRGNAM-$VERSION $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
tar xvf $CWD/$SRCNAM.tar.gz
-mv nicolas33-offlineimap-94450e9 $PRGNAM-$VERSION
+mv nicolas33-offlineimap-b1bff15 $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
chown -R root.root .
@@ -59,11 +63,8 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-### fix the manual file to build correctly
-patch -p0 < $CWD/patches/manual.rst.patch
-
### Patch makefile to disable building dev docs
-patch -p0 < $CWD/patches/doc_generation_fix.patch
+patch -p0 < $CWD/patches/Makefile.doc.patch
### build and install
python setup.py install --root=$PKG