summaryrefslogtreecommitdiffstats
path: root/network/qutim
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2012-09-05 22:40:56 +0200
committer Robby Workman <rworkman@slackbuilds.org>2012-09-08 17:28:30 -0500
commit60ae2f5bd09c3bae3a1b10aab95ed9927638a688 (patch)
treedf53abe888ee3b0c15bb6e282b1d2a4690955c99 /network/qutim
parent15f3ef5eb532b258a561be4e0b7b459182444e63 (diff)
downloadslackbuilds-60ae2f5bd09c3bae3a1b10aab95ed9927638a688.tar.gz
slackbuilds-60ae2f5bd09c3bae3a1b10aab95ed9927638a688.tar.xz
network/qutim: Added (qt instant messenger).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'network/qutim')
-rw-r--r--network/qutim/README4
-rw-r--r--network/qutim/doinst.sh3
-rw-r--r--network/qutim/qutim.SlackBuild123
-rw-r--r--network/qutim/qutim.info10
-rw-r--r--network/qutim/slack-desc19
5 files changed, 159 insertions, 0 deletions
diff --git a/network/qutim/README b/network/qutim/README
new file mode 100644
index 0000000000..852f474bc8
--- /dev/null
+++ b/network/qutim/README
@@ -0,0 +1,4 @@
+qutim (qt instant messenger)
+
+qutIM is free and open-source multiprotocol (ICQ, Jabber, Mail.Ru,
+IRC, VKontakte) instant messenger.
diff --git a/network/qutim/doinst.sh b/network/qutim/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/network/qutim/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/network/qutim/qutim.SlackBuild b/network/qutim/qutim.SlackBuild
new file mode 100644
index 0000000000..babef25028
--- /dev/null
+++ b/network/qutim/qutim.SlackBuild
@@ -0,0 +1,123 @@
+#!/bin/sh
+
+# Slackware build script for qutim
+# Copyright by Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy 2012
+# Based on slackbuilds.org perl template.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=qutim
+VERSION=${VERSION:-20120728_c85176a}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+DOCS="AUTHORS CCBYSA COPYING GPL README.mediawiki"
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# detailed cmake options are from archlinux
+# https://aur.archlinux.org/packages/qu/qutim-git/PKGBUILD
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DQRCICONS=0 \
+ -DQMLCHAT:BOOL=0 \
+ -DKINETICPOPUPS:BOOL=0 \
+ -DASTRAL:BOOL=0 \
+ -DVKONTAKTE:BOOL=0 \
+ -DPLUGMAN:BOOL=0 \
+ -DSCRIPTAPI:BOOL=0 \
+ -DSTACKEDCHATFORM:BOOL=0 \
+ -DMOBILEABOUT:BOOL=0 \
+ -DKINETICSCROLLER:BOOL=0 \
+ -DWEBKITSTYLE/MAEMO:BOOL=0 \
+ -DMOBILECONTACTINFO:BOOL=0 \
+ -DMOBILESETTINGSDIALOG:BOOL=0 \
+ -DDECLARATIVE_UI:BOOL=0 \
+ -DSYMBIANINTEGRATION:BOOL=0 \
+ -DMACINTEGRATION:BOOL=0 \
+ -DMAEMO5INTEGRATION:BOOL=0 \
+ -DMEEGOINTEGRATION:BOOL=0 \
+ -DMULTIMEDIABACKEND:BOOL=0 \
+ -DANTIBOSS:BOOL=0 \
+ -DWININTEGRATION:BOOL=0 \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir $PKG/usr/doc
+mv $PKG/usr/share/$PRGNAM/doc $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/qutim/qutim.info b/network/qutim/qutim.info
new file mode 100644
index 0000000000..f58ed6da6b
--- /dev/null
+++ b/network/qutim/qutim.info
@@ -0,0 +1,10 @@
+PRGNAM="qutim"
+VERSION="20120728_c85176a"
+HOMEPAGE="http://qutim.org/"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/qutim-20120728_c85176a.tar.xz"
+MD5SUM="46c4a72b54a504babc6fbb964dd55980"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"
diff --git a/network/qutim/slack-desc b/network/qutim/slack-desc
new file mode 100644
index 0000000000..73620dc222
--- /dev/null
+++ b/network/qutim/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+qutim: qutim (qt instant messenger)
+qutim:
+qutim: qutIM is free and open-source multiprotocol (ICQ, Jabber, Mail.Ru,
+qutim: IRC, VKontakte) instant messenger.
+qutim:
+qutim: homepage: http://qutim.org/
+qutim:
+qutim:
+qutim:
+qutim:
+qutim: