summaryrefslogtreecommitdiffstats
path: root/network/rdma-core
diff options
context:
space:
mode:
author GUAN Xin <guanx.bac@gmail.com>2023-09-21 22:41:22 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-23 08:42:56 +0700
commitdceb0f34f8b534b817a7d51e353209ec7bcb049c (patch)
treeb2b89d4831c5b1094bf485a0c04817f27c491a84 /network/rdma-core
parent5d335bab3f62257bb5a739c9d7d6b658d082f255 (diff)
downloadslackbuilds-dceb0f34f8b534b817a7d51e353209ec7bcb049c.tar.gz
slackbuilds-dceb0f34f8b534b817a7d51e353209ec7bcb049c.tar.xz
network/rdma-core: Updated for version 48.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/rdma-core')
-rw-r--r--network/rdma-core/optional_pandoc.patch37
-rw-r--r--network/rdma-core/rdma-core.SlackBuild10
-rw-r--r--network/rdma-core/rdma-core.info6
3 files changed, 33 insertions, 20 deletions
diff --git a/network/rdma-core/optional_pandoc.patch b/network/rdma-core/optional_pandoc.patch
index 1e435a94b2..fdc0c5c189 100644
--- a/network/rdma-core/optional_pandoc.patch
+++ b/network/rdma-core/optional_pandoc.patch
@@ -1,10 +1,7 @@
-The master "CMakeLists.txt" listed "pandoc" as an optional dependency,
-but subsequent "make install" fails if "pandoc" is missing.
-This patch makes "pandoc" really optional.
-diff -ru rdma-core-25.0.orig/CMakeLists.txt rdma-core-25.0/CMakeLists.txt
---- rdma-core-25.0.orig/CMakeLists.txt 2019-07-26 02:17:21.000000000 +0800
-+++ rdma-core-25.0/CMakeLists.txt 2019-07-31 00:08:41.485085990 +0800
-@@ -602,11 +602,17 @@
+diff -ru rdma-core-48.0.orig/CMakeLists.txt rdma-core-48.0/CMakeLists.txt
+--- rdma-core-48.0.orig/CMakeLists.txt 2023-09-18 13:24:24.000000000 +0800
++++ rdma-core-48.0/CMakeLists.txt 2023-09-18 14:59:56.134525340 +0800
+@@ -708,27 +708,41 @@
add_subdirectory(kernel-headers)
# Libraries
add_subdirectory(libibumad)
@@ -22,15 +19,19 @@ diff -ru rdma-core-25.0.orig/CMakeLists.txt rdma-core-25.0/CMakeLists.txt
# Providers
if (HAVE_COHERENT_DMA)
-@@ -614,13 +620,19 @@
- add_subdirectory(providers/cxgb3) # NO SPARSE
+ add_subdirectory(providers/bnxt_re)
add_subdirectory(providers/cxgb4) # NO SPARSE
add_subdirectory(providers/efa)
+if (PANDOC_FOUND)
add_subdirectory(providers/efa/man)
+endif()
+ add_subdirectory(providers/erdma)
add_subdirectory(providers/hns)
- add_subdirectory(providers/i40iw) # NO SPARSE
+ add_subdirectory(providers/irdma)
+ add_subdirectory(providers/mana)
++if (PANDOC_FOUND)
+ add_subdirectory(providers/mana/man)
++endif()
add_subdirectory(providers/mlx4)
+if (PANDOC_FOUND)
add_subdirectory(providers/mlx4/man)
@@ -40,10 +41,22 @@ diff -ru rdma-core-25.0.orig/CMakeLists.txt rdma-core-25.0/CMakeLists.txt
add_subdirectory(providers/mlx5/man)
+endif()
add_subdirectory(providers/mthca)
- add_subdirectory(providers/nes) # NO SPARSE
add_subdirectory(providers/ocrdma)
-@@ -639,7 +651,9 @@
+ add_subdirectory(providers/qedr)
+@@ -738,15 +752,21 @@
+ add_subdirectory(providers/hfi1verbs)
+ add_subdirectory(providers/ipathverbs)
+ add_subdirectory(providers/rxe)
++if (PANDOC_FOUND)
+ add_subdirectory(providers/rxe/man)
++endif()
+ add_subdirectory(providers/siw)
+
+ add_subdirectory(libibmad)
+ add_subdirectory(libibnetdisc)
++if (PANDOC_FOUND)
add_subdirectory(libibnetdisc/man)
++endif()
add_subdirectory(infiniband-diags)
add_subdirectory(infiniband-diags/scripts)
+if (PANDOC_FOUND)
diff --git a/network/rdma-core/rdma-core.SlackBuild b/network/rdma-core/rdma-core.SlackBuild
index 8e5a8624c6..3837bff8f6 100644
--- a/network/rdma-core/rdma-core.SlackBuild
+++ b/network/rdma-core/rdma-core.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for rdma-core
-# Copyright 2019 GUAN Xin from Beijing
+# Copyright 2019-2023 GUAN Xin from Beijing
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=rdma-core
-VERSION=${VERSION:-25.0}
+VERSION=${VERSION:-48.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -98,6 +95,9 @@ cd build
make install DESTDIR=$PKG
cd ..
+# Remove systemd stuff
+(cd $PKG/usr/lib${LIBDIRSUFFIX} && rm -r udev/rules.d/60-srp_daemon.rules systemd)
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/network/rdma-core/rdma-core.info b/network/rdma-core/rdma-core.info
index d212158b1d..2f7e7a100f 100644
--- a/network/rdma-core/rdma-core.info
+++ b/network/rdma-core/rdma-core.info
@@ -1,8 +1,8 @@
PRGNAM="rdma-core"
-VERSION="25.0"
+VERSION="48.0"
HOMEPAGE="https://github.com/linux-rdma"
-DOWNLOAD="https://github.com/linux-rdma/rdma-core/archive/v25.0/rdma-core-25.0.tar.gz"
-MD5SUM="48b2bec693fec7d1755a5e99a5d3678b"
+DOWNLOAD="https://github.com/linux-rdma/rdma-core/releases/download/v48.0/rdma-core-48.0.tar.gz"
+MD5SUM="f8901665b2fbf03b4ffb6bf7f6207ac4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""