summaryrefslogtreecommitdiffstats
path: root/network/ufw
diff options
context:
space:
mode:
author Marco Cecchetti <mrc.ildp@gmail.com>2010-05-12 23:32:51 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:32:51 +0200
commita349398ca95608852ad5c8ede3ce260741a88766 (patch)
treed4e29cc0d708300b533e72636266761348adc722 /network/ufw
parenteb42fe905b911cc35ad7de7014a332dc853657fe (diff)
downloadslackbuilds-a349398ca95608852ad5c8ede3ce260741a88766.tar.gz
slackbuilds-a349398ca95608852ad5c8ede3ce260741a88766.tar.xz
network/ufw: Added to 12.2 repository
Diffstat (limited to 'network/ufw')
-rw-r--r--network/ufw/README28
-rw-r--r--network/ufw/slack-desc20
-rw-r--r--network/ufw/ufw.SlackBuild54
-rw-r--r--network/ufw/ufw.info8
4 files changed, 110 insertions, 0 deletions
diff --git a/network/ufw/README b/network/ufw/README
new file mode 100644
index 0000000000..2b700eefe6
--- /dev/null
+++ b/network/ufw/README
@@ -0,0 +1,28 @@
+Ufw (Uncomplicated Firewall) is program for managing a netfilter firewall.
+It provides a command line interface and aims to be uncomplicated and easy
+to use. It is not intended to provide a complete firewall functionality via
+its command interface, but provides an easy way to add or remove simple rules.
+
+To run ufw at boot you can add the following code to rc.local file:
+
+if [ -x /etc/init.d/ufw ]; then
+/etc/init.d/ufw start
+fi
+
+Rules can be added with ports, services or application names. To specify an
+application you need a profile stored under /etc/ufw/applications.d directory.
+
+To add a profile create a app_name.INI file as the following:
+
+[Samba]
+title=File/printer server for Unix
+description=Samba is a collection of programs that implements the SMB/CIFS protocol for unix systems.
+ports=137,138/udp|139,445/tcp
+
+Then, for example you can run:
+ufw allow from xx.xx.xx.xx app samba
+
+
+
+
+
diff --git a/network/ufw/slack-desc b/network/ufw/slack-desc
new file mode 100644
index 0000000000..440afd4e73
--- /dev/null
+++ b/network/ufw/slack-desc
@@ -0,0 +1,20 @@
+IT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+ufw: ufw (Uncomplicated Firewall)
+ufw:
+ufw: Ufw is a program for managing a netfilter firewall. It provide a
+ufw: command line interface and aims to be uncomplicated and easy to use.
+ufw:
+ufw: https://launchpad.net/ufw
+ufw:
+ufw:
+ufw:
+ufw:
+ufw:
+
diff --git a/network/ufw/ufw.SlackBuild b/network/ufw/ufw.SlackBuild
new file mode 100644
index 0000000000..57c38d297c
--- /dev/null
+++ b/network/ufw/ufw.SlackBuild
@@ -0,0 +1,54 @@
+#!/bin/sh
+# Slackware build script for ufw
+# Written by Marco Cecchetti (mrc.ildp@gmail.com)
+
+PRGNAM=ufw
+VERSION=${VERSION:-0.27}
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python ./setup.py install --root=$PKG
+
+
+mv $PKG/usr/share/man $PKG/usr/man
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/etc/init.d
+
+ln -s /usr/share/ufw/ufw-init $PKG/etc/init.d/ufw
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS ChangeLog* COPYING README* TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+
diff --git a/network/ufw/ufw.info b/network/ufw/ufw.info
new file mode 100644
index 0000000000..c5dbf4c5ba
--- /dev/null
+++ b/network/ufw/ufw.info
@@ -0,0 +1,8 @@
+PRGNAM="ufw"
+VERSION="0.27"
+HOMEPAGE="https://launchpad.net/ufw"
+DOWNLOAD="http://launchpad.net/ufw/ufw-0.27-jaunty/0.27/+download/ufw-0.27.tar.gz"
+MD5SUM="acad0f150d7c58dccd97348215c1652f"
+MAINTAINER="Marco Cecchetti"
+EMAIL="mrc.ildp@gmail.com"
+APPROVED="dsomero"